Access to Red Series Dimmer LED Bar via Hubitat

hello, i use a red series dimmer with hue lights. i put the switch in smart bulb mode and disabled local control. everything is working fine. what i miss is the LED animations that the switch has in normal local mode, like the “ramp up” and “ramp down” animations when you turn the light on/off, and the gradual increase/decrease animation during button holds for dimming.

in hubitat, i created a rule based on button turning switch on, it will also turn on “notification 1” which is set to blue, 100%, indefinite, solid. then when i turn the switch off, i have another rule that turns on “notification 2” which is set to blue, 10%, indefinite, solid. this changes the intensity of the LED bar based on if the switch is on/off, but is there a more elegant way of doing this?

i would really like to be able to access the stock on/off and dimming animations via hubitat, is this possible, or is there another workaround someone can show me?

In this scenario I think you don’t want to disable local control. Smart Bulb mode will keep power to the bulb. With local control enabled, the LED bar should behave like it normally would

when i had enabled local control, two things happened:

  1. if i dimmed all the way down, or clicked the switch off, the hue bulbs would lose power. i would not be able to control them with voice via alexa unless the switch was turned back on. can someone verify that smart bulb mode will keep power going to hue bulbs? is there another configuration i did wrong because i could not keep power to the hue bulbs.

  2. i got really bad flickering during dimming. anything below ~50% would cause flickering. i did read something about settings to limit what % the switch would dim to, but i could never get around issue 1. i’ve got my mom living with me and she is 70+. she refuses to deal with smart anything and cannot accept that some buttons will not behave in the traditional dumb way, so i have to find solutions where the “smart” way and “dumb” way can co-exist and work.

Sounds like you are running older firmware. Update your firmware to get the new-and-improved SBM which lets you select either “on/off” mode or “always on” mode

Yes there is a “Minimum Level” setting that you should configure. It currently can’t go higher than 45 (requested to be higher in future firmware update) but that should get you close to what you need.

There are other parameters you can set to make the switch/dimmer act more ‘traditional’. Thing like “disable delay” and settings for ramp rates to make the lights turn on/off faster. However, these settings are for directly controlled loads and don’t really apply to Smart Bulbs which are controlled via Z-wave radio commands

I don’t think you can keep the dimmer animations in your scenario. The LED level is tied to the switch output and we do not have a way to command it from the hub. You do want disable local control on, and will send commands to the Hue bulb initiated from the scene commands the switch sends to your hub. I’ve specifically set up all Hue bulbs in my house to be controllable as normal dimmed bulbs so that the smarts are hidden from those that don’t want to be involved in them, which I think is your intention here.

I really think smart bulb mode is unnecessary if you don’t want to go through firmware updates. Disable local control and remote control, then set your parameters 6 & 11 to 99. This will ensure the switch always passes maximum power even after a power failure. The bulbs will live a very short life if you try to dim them from the wall.

You can with the latest firmware using the new-and-improved Smart Bulb Mode

Not with the current firmware. The LED bar tracks the internal SetLevel dimming value even though the output terminal is fixed at 100% on.

Not if he wants the LED bar dimming to work with local switch presses and the new SBM mode enabled.

I suppose that is true if you don’t want to update the firmware. But why not? The new firmware will do what he wants.

Not without updating to the new firmware. With the old SBM firmware there is no dimming of the load, which is important for Smart Bulbs. But the load can still be turned off which kills power to the smart bulb and it can’t be controlled from the hub until the switch is turned back on. The new firmware with the new SBM mode will keep power ‘On’ ALL THE TIME. This allows the bulb to still receive commands from the hub even when the switch is off.

Thanks @mamber. I tried to see how smart bulb mode ended up via google and never found the final answer. It is more useful than I thought it ended up being.

thank you everyone for the insight. i will try to first update the firmware and then go back to local control and see how it goes. will report back later.

If you haven’t done it before, be aware that Inovelli Dimmers have TWO files you need to flash.
There is a .otz file you flash to target0
There is a .bin file you flash to target1

To get all the new SBM functionality you’ll want to get those files from here:
https://files.inovelli.com/firmware/LZW31-SN/Beta/1.57/

it works! it’s so hard to keep up with all the changes to inovelli products - drivers, firmware…i must have missed where the smart bulb feature will apply continuous power, but yes, it does work. i have re-enabled local control, so the inovelli dimmer works with all the default LED bar animations, alexa works, hubitat works, everything is perfect now.

thanks, on to the next project!

1 Like