Accidentally flash switch firmware on dimmer


I was upgrading firmware on my dimmers and switches (1.45 and 1.17). Using Aeotec gen5 stick and Z-Wave PC Controller app on Windows 10. I accidentally flashed 1.17 on one of my dimmers. Did I brick it? I can’t get it to response to any commands. Tried cutting power to dimmer to reset, nothing. LED strip flashes color when power is supplied, but then just goes off right after cycling through blue/red/green.


This is something @EricM_Inovelli might be able to help you with. In the mean time I would do nothing more with the device.

If you can exclude it and include it back into the PC Controller software you can flash it to the correct firmware. Can you get that far with it?

yea, I cannot exclude it or include, as after it powers on, the LED strip goes dark and switch does not respond to any input. I took the Aeotec gen5 stick from hub and put it into PC with Z-Wave PC Controller.

Ironically, the dimmer is lucky z-wave node 13 :slight_smile:

Took of video of toggling the power to dimmer (far right dimmer):

Trying to get node info, nothing:

Trying to get firmware info, nothing. Neither of the 2 targets or any info at the top are present after hitting the “Get” button multiple times.

Any update? If I bricked it, I’d like to know, so I can order a replacement, it looks like things are back-ordered and this switch controls my dining room lights…

I guess at this point I am going to assume I bricked it.

Yeah. I don’t think there is any coming back from that. If you could get it to exclude and include you can flash the correct firmware. This sometimes works. None of the functionality of the device will work as far as on / off, LED bar, etc. but it will still include. If it can’t even do that then it is dead. :frowning:

Is your dimmer wired up with or without a neutral? If you have no neutral, it might be worth trying to wire it up in a location with a neutral to see if you can re-flash it then.

Also, did you try a factory reset (hold config button 30 seconds)?

I actually haven’t tried anything other than what I put in the video. It is wired with a neutral. I am going to try and exclude/include (even with the LED bars not working) and then maybe a factory reset, before replacing dimmer.

Thanks for feedback.

unfortunately i tried to exclude even with the LED not working, i tried factory reset, etc, nothing brings it back to life. I just marked the node as failed using Z-Wave PC Controller, then removed failed, and trying to figure out how to get a Red series dimmer to replace it now, as there is no stock available anywhere… lol