All my red series dimmers changed to red

Has something changed? All of my dimmers led dimmers have been blue since I installed. I came downstairs this morning and noticed all 3 of them are a different color now. I don’t have any notifications set up. All are working as should both at the switch and thru smart things. I went into setting and yes they are set to blue…but are still showing red. What’s changed?

it happened to me once that Google showed my red and black switches as lights and when I asked Google to change the lights to any given color, the switches would change the LEDs accordingly too (since Google thought they were bulbs too)

don’t know if something similar is happening to you.


Gives me something to try when I get home. I do have some light strips in a different room. Did you just go by them and tell Google to change lights to whatever color you want? Is that how you “fixed” it? I tried settings but it won’t change them.

first you need to check if your switches appear as lights in Google home (I’m assuming you use Google assistant).

if they do show as bulbs, then the assistant could get confused and change the LEDs too.

at that time Eric told me to remove some string in the device handler so Google wouldn’t recognize the switch as a bulb but now that I think about it… how do you name your switches in smartthings? (you use smartthings, don’t u?)

if you name a switch “light”, Google home assumes it’s a light bulb and treats it as such. if that’s the case, try renaming it differently, “kitchen” instead of “kitchen light”, for instance. just to see how Google recognizes the switch. you can change rename it to whatever you want in Google home later.

I’ve been trying change the color of my LEDs with Google Home and haven’t been able to do that. So I’m not saying that is what caused the issue, but you might look in other places as well.

What strikes me as strange is that you are unable to reset the color of the LED via settings in the ST app. Regardless of how the LED is changed, you ought to be able to reset it via the app’s settings. AFAIK, there isn’t anything that should “lock” the LED color so that it can’t be changed.

Try pulling the air gap for 10 seconds or so to reboot.

You can also look at the device’s page in the IDE. Go to the bottom and see what the devices are in use by. That might give you some other places to look. You can also look at the recent events to see if anything jumps out at you.

Thats exactly what it was. My daughter has light strips in her room. When I changed the color the other night it must have changed them also. I went to the basement with my phone and said “hey google, change the lights to blue” and it changed all the switches back to blue.
In smartthings, they are switches, but in google home they appear as lights or bulbs. I’ll try to rename them later and see if that does anything.

1 Like

I found when I go to my goggle home settings, at the bottom it shows color. I can change the color of the strip there.

Interesting. Mine are shown as lights in GH too. I have that color control, but selecting colors after opening it doesn’t budge my LED. You just never know . . .

you can change the device type for anything else other than a light bulb. I got mine set up as switches and the problem is solved.

when you ask Google to turn on/off “the light” and that particular speaker doesn’t have a light (switch or bulb) associated to the same room that speaker is in, it will turn all the lights in that home. the same goes for the color or intensity.

this is how I changed the device type in Google home. open the switch you wanna change, go to its setting and there you’ll see it

Do you know what to do if you don’t have the device type option? Is this where the rename comes in?

You can see at the bottom it is seeing it as a light instead of a switch like yours.

as far as I remember, there was some string I was told to remove from the device handler but recently I installed the most recent version and didn’t have to remove anything.

do you have the latest DH installed for that switch?

I believe so…but where can I find that out to make sure? Like I said, it’s showing up in smartthings as a switch, but GH as a bulb.

I believe the latest device handler had this string that causes the issue removed. that allow you to change the device type in GH

Where do you find the version of the dh?

Ok, so I found the one i have. Pretty sure it’s an older one. Last update says 1-28-21. So do I just copy all that code and delete? Then copy and paste the new one or do I create a whole new one and publish that one?

And is there a way to automatically get the updates?

Yep, open the existing one, select all and delete the old one. Paste in the new one. Then Publish, For Me.

Not exactly automatic, but you can link the ST IDE to Github. That will allow you to click on the “Update From Repo” button in the IDE’s DH page. That will show you a list of obsolete handlers and allow you to update them. Once it’s linked, select “Update From Repo” and then "SmartThingsInovelli (master). Check mark the ones you want to update and then click “Execute Update”.

I can’t remember how I did the linking, but I found this: