Am I doing this right? LZW31-SN Range Check goes green to red

I have read what I could find on this and just looking for confirmation that I am running the range check correctly – I hold the config button until it turns green (5 secs) and then let it go - turns red. I understand this to mean out of range. If I hold for 10 secs, it goes from green to yellow and then into red factory reset at 20 secs.

I have 2 LZW31-SN dimmers installed and after many, many resets, exclusions, and pairing attempts, I finally got them to pair by bringing the hub to within 10’ and then doing a repair back at the base location after each. One is next to a GE switch and I just added an Aeotec repeater less than 10 feet away, line-of-sight, I did the z-wave repair and then did a range check Still goes from green to red when I release the config button. Am I reading it wrong, is the range function faulty, or Twilight Zone?

You’re not wrong. I reported this as soon as my first switch went in.I have multiple that reports green to red, but the regular on/off switch shows good indication.

1 Like

Range check is 3 presses of the config button.

3 presses of the config button is for pairing.

Yep, OP is correct. 5 - 10 sec press for signal strength.

Whoops, misunderstood. You are right.

My first dimmer I installed in my shop (60+’ away) the range lit green the first try. I changed locations to the basement no signal, to kitchen as the hub is 15’ away, lit red until I removed it from the box then paired fine. I figured the LED Tubes I run in the Garage area of the shop would affect it more during my testing as my shop is plagued with RF noise, but it worked flawlessly running my 3 4" 9.5W LED Downlights. I have another to install yet and test. I also have a Red Series switch that paired first time without issue. Z wave seems less prone to the RF noise present as my wi fi and Zigbee devices will do flaky things now and then.

I have given up on the range check I now have a GE, and 2 LZW31-SNs in the same box and all are paired and work fine, but of the LZWs will pass range check

Has anyone tried updating their firmware? What about using the zwave association tool?

I have a switch that does this. I cannot setup a group 2 or group 4 association between it and an inovelli rgbw bulb. Firmware updates consistently tail trying to upload. Testing my zwave signal goes green then red. This same setup has worked flawlessly in three other spots on my house on the same hub. This is driving me crazy.

I found the RF range check went from Green to Red after initial installation of my LZW31, before inclusion with the Hubitat.

After inclusion and the device was paired and configured, the RF check displayed Green with no following Red.

I assumed the second Red indication was a reminder that the dimmer was not paired with the hub.


I have the issue with dimmers paired with the hub. The operation of the devices is expected, with the exception of the inability to upgrade the firmware.