Blue 2-1 success! (kind of?)

I received my Blues today! And you know what, they work without a neutral, without a bypass. Mine control an array of LED ceiling downlights (6x10w each) and there’s no flickering or any issues while off.

However, I am running into a few issues:
The main one is the “dimmingSpeedUp” remote/local is not the same scale as dimmingSpeedDown. Down seems to have that “only 1-3 of 255 are useful speeds, 4-255 are too slow” issue. But dimmingSpeedUp needs to be set to ~20 in order to match the speed for dimmingSpeedDown 3. Anything going on here?

Also, the lights keep a memory of the last “on” level when they’re turned off, such that they resume next time they’re turned on. That’s fine, but tapping “on” again doesn’t increase the brightness. I feel like a second “on” tap should bring it to full. Is there a way to do this? I know I can set double-tap to 100% load, which is a workaround I’m using now.

What hub?

What is happening is actually the on tap is going to the “default local level”. If you want it to be last state, then it will just stay at the level it currently is on. If you want it to go to 100%, adjust the default local level accordingly. The double tap to 100% was implemented for this reason as well.

I could potentially see the firmware being updated to improve such that it goes like this:

IF up paddle is pressed
AND switch is off
THEN go to default level
ELSE go to 100%

No hub, HA with Z2M.

So, a couple of things. 1) Maybe this is a Z2M thing, but defaultLevelLocal (and Remote) have sliders that only go to 100, but they’ll accept numeric inputs to 255 (which is actual full brightness).

  1. defaultLocal seems entirely ignored. If the switch ALWAYS goes to the last current level before being turned off, there’s no time it ever uses the default. Is there a toggle that lets the light “always use defaultLevel rather than last level?”

Update, the second Blue is running as well, also without a neutral and no bypass! So far, both of the configs I use are fine without bypasses:
Cree LED downlights (~36w)
Cree LED downlights (~60w)

1 Like

Yep the team is fixing the driver for Z2M.

Setting default to 1 should ALWAYS go to 1 (well 3 right now due to scaling) when the up paddle is pressed once, no matter current state (on/off). If that is not the case we can look into it. On ZHA this was how it worked for me.

A few quick updates and a question. Maybe this is just my pure ignorance setting in…

defaultLocal DOES work, but because the z2m slider only goes to 100 (which is not 100% brightness), I manually set it to 255, which Z2m accepts. But the actual top of the range is 254. So if I lower it to that, it works.

  1. I messed with individual LED bar settings and now they don’t work right. They’re stuck at whatever I set them at, but the Controls UI reports them as 0, so I don’t know what needs to be manually adjusted. Is there a way to reset it to default? I imagined that re-selecting values for the global “ledColorWhenOff” would work, but they don’t override whatever defaultLedXColor is. Right now, I have to guess the LED number, then manually match and input the color and intensity to what I have in global “ledColorWhenOff/On” and submit that, which is a bit of a pain. And I anticipate they’ll stick at those values if I later want to change ledColorWhenOff to something else.

  2. Lastly, when I load up the control/exposes screen in Z2M, a lot of them seem randomly set. In this screenshot below, why is defaultLed1IntensityWhenOff set to 101? I never changed that? And if I check it later in the day, it will be at 0 and some other values will be all over the place.