Blue Zephyr not responding to double tap scene control - Smartthings

I just bought a Blue Zephyr switch and tried getting the taps to control routines via Smartthings. I really wanted to use the aux button for this and started with that but am not seeing any events fire from the button presses and the routines do not activate. I tried different combinations of double taps, on the padle, double and single taps on the aux etc. and none of them appears to be firing off a button press that Smartthings can see.

Is there a firmware fix or driver update needed to make this work or is something else going on?

Nothing special needed. What is your P50, Button Press Delay set to? When button presses don’t register it’s typically because the delay is set too low or turned off. Leave it at the default to start with. 500 ms.

Mine is set to the default value. Should I try setting it to 1 second to see if that helps?

The default of 500 works fine for me.

Can you post a routine that isn’t working?