Can't choose option 101 for parameter 11/7 presses (power on state)?

Parameter 11 (which you get to by pressing config 7 times) defines what level lights return to after a power outage. the power on state or POS ;-). The default that the lights are set to 0% after a power failure is an interesting design choice… (as would be a default to set the lights back to some fixed number after a power failure… power fails and your lights that where off are now turn on??).

so the only setting that makes sense (to me) is that the lights turn back on to their latest level on a power failure recovery. and that’s option 101 (!!)

but how do you set that option to 101?? click 101 times on on POS option on my 30 switches?

i did try clicking 101 times on one switch (and also found that holding down thd paddle for a VERY long time like 2 mins seems to do it without having to click indiviually 100 times). But the switch seems to only want to go as high as 10 long yellow blinks (which is 100, not 101) so i can’t figure out how to set it to 101 so my lights resume after a power failure.

anyone else think that turning the lights off/set to 0 is a weird default? anyone else figure out how to set it to 101?

  • i don’t have these on a hub, so i can’t use the hub to make the setting.
    ** actually, i have a vera hub, but these switches don’t work with vera hub even as a generic z-wave switch, see other topics on that matter.

Hubitat is on sale right now for $70. Best $70 you will ever spend. These products from Inovelli really are at their best when used with a hub!

@vmChad - Definitely agree. I have a SmartThings v3 hub that I used for over a year. First Inovelli switch installed and about 3 days trying to use ST and Inovelli together, I ordered a Hubitat to replace it. Glad I did!

thanks for the hub advice. (i ordered a hubitat to give it a try).

this question is about how to set the switches so that they reset to the same level after a power failure. anyone know how to do that?

Ran across this thread while searching after checking things with the Hubitat basic Z-wave tool.
I am unable to set parameter 11 to 101 - I try to set to 101 and it stays at 100.
Maybe a firmware bug?

This is an old topic, but I am running into the same issue with Inovelli Red Dimmers (firmware is v1.57), and this is the latest version. Trying to set it to 101 simply fails and resets the value back to whatever it was previously. I am using Zwave2Js on Home Assistant. From what I can see, this is the only property that does this.

I am able to set it to any value <= 100 (0 being “off”, 100 being 100% brightness), but 101 does nothing. I suspect the firmware on the switch is validating that the value is between [0, 100].

EDIT: command class does show the max value as 101 from the ZwaveJs side:

      "id": "10-112-0-11",
      "nodeId": 10,
      "commandClass": 112,
      "commandClassName": "Configuration",
      "endpoint": 0,
      "property": 11,
      "propertyName": "Brightness After Power Failure",
      "type": "number",
      "readable": true,
      "writeable": true,
      "label": "Brightness After Power Failure",
      "default": 100,
      "stateless": false,
      "commandClassVersion": 1,
      "min": 0,
      "max": 101,
      "list": true,
      "allowManualEntry": true,
      "states": [
          "text": "Off",
          "value": 0
          "text": "Previous state",
          "value": 101
      "value": 0,
      "lastUpdate": 1648189262102,
      "newValue": 0,
      "toUpdate": false

101 is not a valid value. The value for Parameter 11 (State After Power Restored) to return to previous is 100.

Maximum brightness in Z-Wave is 99. The values range from 0 -99.

I haven’t tested, but that is how it is documented in the ST 1.61 driver. So you are correct that the switch is the evaluating the input and not allowing 101. Same thing happens in ST.

1 Like

It looks like the official documentation defines it as 101, which is keeping in line with what the other values use as a “special” value (i.e., syncing ramp up values with parameter 1). But obviously, since it doesn’t accept 101, it’s probably wrong. Who can fix the documentation? I can put up a diff for Zwavejs.

Created pull request on Z-Wave JS here: Correct LZW31-SN definition to use correct value by amcfague · Pull Request #4409 · zwave-js/node-zwave-js · GitHub

1 Like

Can you update the link you posted, as it doesn’t resolve?

For reference, here is the line in the LZW31-SN ST driver I relied upon:

parameter.parameter11description=“The state the switch should return to once power is restored after power failure. 0 = off, 1-99 = level, 100=previous.”

It’s the manual link for the LZW31-SN, but this is what redmumba is referring to -

1 Like

@Eric_Inovelli @EricM_Inovelli - Tech manual update?


Confirmed that “100” restores to previous state after an outage on 1.61.

1 Like

That is correct, @chack, thank you–it looks like the PDF is generated from a script so not possible to link it directly from what I can see, but it’s the manual at the bottom of the spec sheet.

EDIT: PR was approved for Zwavejs.

My bad guys, just updated the manual for both the Black and Red Series.


Thanks for the quick update, @Eric_Inovelli! Love the Red Switch… really looking forward to the Z-wave chips to start flowing again so I can replace more switches–you guys have made an awesome product! :slight_smile:

1 Like

Yeah no problem! I’m excited about getting all the documentation in the knowledge-base in the community so we can change these things in real-time and keep our documents up to date and accurate. Sorry about the confusion!

I’m pumped too – hopefully soon. We did hear some good information from our ZigBee manufacturer regarding Z-Wave, so there’s hope!