Ceiling Fan Stopped Working - But Hubitat thinks it is on

I have 5 fan/lights. I’ve been doing excludes/includes on them to remove security so I can use the Z-Wave Firmware Updated app to take them from 1.34 to 1.36 so I can disable the physical delay.

I’ve done 3 of them without out problem, one I cannot get to exclude (along with several other devices which have been causing me to do multiple Hubitat shutdowns and reboots the last several days - but that is a different problem) and one that looked like it worked, but the fan is not working. I noticed the fan LED was on and when I pushed it to turn it off it did go off. But when I tried to turn the fan back on the LED lit up but the fan didn’t start turning. I am currently on Hubitat 2.2.6.139 but did the firmware to update this problem fan to 1.36 some while ago, so I’m not sure which version of Hubitat I was on at the time. I hardly ever use this fan so I’m not sure when it stopped working, but it was working as recently as of a couple of weeks ago or so and my daughter told me tonight that when she tried to turn it on this afternoon it wasn’t working. (Which is probably why the LED was on).

Here may one other very relevant factor: yesterday my electricians put in 6 Red Dimmers. One was in the same room, but it is NOT on the same circuit. (I just verified that by throwing the breaker). I also threw the breaker as I saw an old, pre 1.34 thread that said turning the power off and on helped. That didn’t work here either. I even tried to re-pair it again after turning the power back on with the same non-result - i.e. both LEDs blink green for a while, and then turn off, but the fan is still not working.

BTW, the fan was not on during any of those times if that is also relevant.

One other BTW, I did try to re-pair it to the module by holding button D and pressing E 3 times quickly. The 2 LEDs instantly turned green and started blinking. I waited until the blinking stopped and tried it again. Still nothing from the fan.

If I go into the child device in Hubitat and push “On” it says it is on and the LED lights up on the switch but the fan won’t start. It is in a very high ceiling so it doesn’t have any pull chains. Help, please.

Here are screen shots of the child device and recent logs.

It is off:

Now it thinks it is on:

Here are the logs:

Dear Eric and Eric M. I’m adding tags to this email as it has been over a day since I posted it and no one has posted any suggestions as to how I can get my fan to start talking to the switch again. Let me know if this was the right thing to do vs. putting in a ticket.

Thank you,

Stuart
@EricM_Inovelli
@Eric_Inovelli

Can you try pulling the airgap on the switch and pushing it back in?

I pulled the air gap and left it out for about 45 seconds. The light still works but the fan still isn’t coming on. Right after that I tried to pair it again by holding button D and tapping E 3 times. The LEDs lit up green and were flashing. I tried the fan after the lights stopped blinking but it is still not working.

Can you check the wire connection at the fan canopy? Seems weird that the fan would just stop working but the light is still working. So I’m not thinking it’s an rf issue.

That’s the only thing I can think of other than factory resetting the device.

That is extremely difficult for me to do. This one is in a very tall ceiling about 10 1/2’ up. My son does have a tall ladder that can get up there, and I used it a couple of weeks ago to change the bulbs (at which time I also ran the fan after we did that, so I know it was working then), but I’d have to get that from him. Plus, I hired an electrician to install all the fan modules as I didn’t want to be trying to do that, particularly for this one that is so high up. I’m not even 100% sure what I would be looking for as I didn’t wire the modules.

If I do a factory reset would that take the firmware back to 1.34? Plus, if I do the factory reset, do I have to do the include again, and pair it to the module again or what?

Thanks,

Stuart

Yes, I apologize for this. Not a fun afternoon.

Since you know the fan worked at one time, I would say the wiring is correct. So, all I would look for now is to make sure the wire-nuts are securely fastened and the wires have a good connection. Sometimes if the wires have a bad connection, it would cause your fan to act this way. Make sure the electricity is off when you do this.

If the wiring connections are good, let’s turn back on the electricity (while leaving the canopy exposed) and try using the fan again from the switch. This will test to see if there’s some sort of communication issue. If everything works, shut the power back off and put everything back to the way it was, then turn the power back on and test again.

No, it will stay at 1.36. You will have to include it again to Hubitat, yes.

Also, to be clear (apologies) – let’s exclude it first from Hubitat (remove) and then pair/include it back to see if that helps at all. If it doesn’t, then let’s exclude it again and then factory reset. Instructions below.

You may have to pair it to the module again – If so, the directions are above.

I got it working!

So 1) please have your people cancel the support ticket I submitted. (I didn’t get an email that the ticket was created and I don’t see another way to send a follow up to a ticket).

I air gapped it again, waited a minute and turned it back on. That might have fixed it. But I think it is possible that myself or someone else in my family had “dimmed” to zero (or at least low enough that it stopped working).

To prevent that from happening in the future I set the Minimum Fan Level Param in Hubitat to 33 (i.e. low). That’s a tip maybe to help others.

Fantastic, that’s great to hear!

I took the ticket myself and responded :wink: – but I’ll close it out for reference.

Dang, I didn’t even think of that being an issue (dim to zero and fan is “off”) – nice catch!

We tried the air gap, which I guess that comes under the “be sure it is plugged in”, but seems this is a corollary.

Next firmware should have firmware to limit dimming to 1 (breeze mode)!