Difficulty Updating Firmware on LZW36 via ZwaveJS

Hi all,
I’m having trouble updating my LZW36 switch from 1.31 to 1.36 using ZwaveJS. I’m trying to upgrade with the .gbl file aiming at “target 0”. I’m able to initiate the upgrade from the ZwaveJS interface and the upload process seems to run (it pauses at places, but resumes on it’s own). But, the first time I ran the upgrade, it finished with “Status: -1” which I assume is bad. After refreshing a bunch, the version seemed to still be 1.31. So, I tried again with another “Status: -1” result. Then, I enabled debug in ZwaveJS, ran the update once more and got a “Status: 4” result. But unfortunately, I think the switch is still stuck at 1.31… at least that’s what the version info seems to still show in ZwaveJS.

I’m not sure if I’m making any mistakes in the process since the instructions from Inovelli reference the .otz file instead of .gbl and seem to assume my hub has no OTA capability. I’m trying to update because my switch is resetting after 130 minutes as I’ve seen mentioned in other threads as being patched in the latest firmware.

Any advice would be welcome–thanks!

I was doing some firmware updates with ZwaveJS last night, but it was .otz/.bin files.
What I was seeing was Status -1 with only a portion of the file uploaded.

I got it down to a process that I think is foolproof (for my network). Some steps might not be necessary, but I did three devices in a row like this.

  1. Pull the air gap on your device
  2. Replace the air gap
  3. Do a “Re-interview node” with ZwaveJS2mqtt
  4. Wait until the interview is Complete.
  5. Do the firmware update on target 0 with your gbl or otz file. It will take a long time. 60-90 minutes. You can see the progress in the top right corner of the ZwaveJS2Mqtt interface
  6. Repeat steps 1-5 with the .bin file on target 1 (if you have one; LZW36 doesn’t have one)

Worked on the first try finishing with “Status: 255” this time. Thanks a lot!

Dang, nice work @melonhead!