"Fake" physical dimmer dilemma

Hi all, first timer here.
Looking for a help and ideas from the community.
Wife purchased a nice Italian LED pendant. Didn’t have any plans to control it, but then I was bored and had no other choice :slight_smile:
What I have:

  1. A regular dumb non-smart on/off switch to turn on/off the pendant
  2. The LEDs in it are apparently dimmable, but only “0-10V” dimmable
  3. Luckily, the pendant has a smart LED driver, specifically “DC MAXI JOLLY HV DALI” (https://win.tcisaronno.com/downloads/?IDnode=5012&field=docs&language=IT)
  4. Only neutral and hot wires are going from the switch through the walls via the ceiling to the pendant

After several dumb mistakes I realized that a real dimmer instead of the dumb switch won’t work as 110V go directly to the LED controller and controller itself should dim the LEDs via 0-10V wires attached to special controller inputs.

Seems like I found the only possible remotely controllable solution in my case: Qubino Z-Wave Plus 0-10 V Dimmer ZMNHVD3 (https://www.amazon.com/gp/product/B01M5FTB27/ref=ppx_yo_dt_b_asin_title_o00_s01?ie=UTF8&psc=1).
I wired it to the LED controller (it’ll live inside the pendant as it also has the AUX 24V output), was managed to include it into Hubitat. I was finally able to dim the LEDs!

BUT it is possible only through Hubitat and not a physical dimmer, which I also want!

Qubino itself has on, off and dim capabilities and is controllable as long as my physical dumb switch is on. It also does have a memory, so it remembers the last state if I turn the switch off.

So here is the problem: is it possible somehow to use Inovelli (or any other physical dimmer) the way that it fully controls Qubino sending on/off (push up/down) or dim (hold up/hold down) via Z-Wave, but does not touch the electricity at all (it’s always on)?

I love Inovelli’s LED showing the dim level!

Looks like this is something similar to previous topic: Smart bulb dimming with Red Series Dimmer (LZW31-SN) on Hubitat
To disable relay, etc…and one of the repliers was able to sync the LED indicator with the dim level…not sure if it was the most efficient way with multiple RuleMachine rules and variables though

If you associate the Inovelli with the Qubino and disable the relay on the Inovelli by pressing the config button 8x, you will have on/off control and dimming. However, you will lose the LED indicator showing the dim level because the switch is essentially locked at 100%.

An alternative solution would be to skip the load wire on the Inovelli and wire the qubino so it is always on, and then set up association on the Inovelli. That will give you on/off, dimming, and an LED indicator bar that shows the dim level.

Hi! I was actually thinking exactly about the 2nd scenario, but wasn’t sure if I can use the dimmer (I guess Red series) without the load wire.

So basically it should be like this:
| . . |
hot neutral
| . . |
|\ . .|____ | Inovelli
|.\ __| ___ | Dimmer
| . . |
| . . |
LED Controller

Does it look right?

If I’m reading that right, it means you have hot and neutral, so the Inovelli dimmer and the LED controller both get hot and neutral, always on, both unswitched. And yes that is exactly what you will need. Inovelli gets hot and neutral (no load), it’s just a control pad. LED controller and Qubino always get power, they are controlled by Z-Wave. Associate the Inovelli to the Qubino and you have your solution- Inovelli controls the Qubino just like it was wired in.

Note Inovelli has 3 association groups. Associate groups 3 and 4 to the Qubino. Then, and this is important, ONLY control the Inovelli dimmer. If you’re sending commands from Hubitat, send them to the dimmer. That way the dimmer’s LED strip stays in sync with the Qubino. If you control the Qubino directly, Inovelli dimmer won’t get that message and the LED strip won’t update. So hide the Qubino in your HA hub and never control it.


If you have a more efficient way of writing these rules, I’m all ears. (Not being a prick…seriously just curious as I’m always trying to get my hubitat to run more efficiently).

Will update. Actually noticed that Inovelli has 2 holes for hot wire, which makes it very convenient for me (no need to do rewiring): both Load and Hot will go into Line, thus making my Qubino always on.

I’m dealing with a connectivity issue though: my Inovelli dimmer is in the middle of the room, but my Hubitat is in the closet. I moved Hubitat closer to the middle of the room in order to include Inovelli, but once I move Hubitat back, Inovelli can’t reach it.
I do have a Zooz ZEN06 smart plug, which is a repeater, which is right near the Inovelli dimmer and the plug doesn’t have any issues with reaching out Hubitat in the closet.
Is there any way to force Inovelli to use repeater in ZEN06 vs trying to reach out Hubitat directly?
Triggering Z-wave repair when Hubitat is in the closet doesn’t do anything.

Do I need to associate it through Association Tool?
Or directly in Inovelli driver? Why do I need 2 groups?
Still figuring it out.

Association tool I think- I’m not that familiar with Hubitat.

The 2 groups are because different groups do different things on a Z-Wave protocol level. This is device-specific, different manufacturers do it differently.

For inovelli, Group 2 sends Basic Set commands. So when you push the paddle up or down, it sends ‘on’ or ‘off’. This will turn the light on and off, nothing more.
Group 3 sends Multilevel Set commands. So when you push the paddle up or down, it sends ‘100%’ or ‘0%’, and when you dim the light it sends ‘39%’ (or whatever you dim it to). This will allow you to dim the light to whatever % you want, but it doesn’t happen live.
Group 4 sends Multilevel Change commands- when you push and hold the paddle it sends ‘start level change’ and when you let go it sends ‘stop level change’. This enables live dimming but won’t otherwise control the light on and off.

Thus, you associate group 3 and 4- Group 3 will forward any level set commands (either pushing the paddle on/off, or on/off/dim commands from the hub), Group 4 forwards live dimming (holding the paddle).

Generally speaking, if you are unable to pair devices in place you need to stop. That typically indicates you have some mesh issues that should be addressed first. Relocating either device will likely result in further mesh issues, such as loss of connectivity to the device.

It sounds like you need more repeaters to strengthen your network. This can be accomplished a few different ways:

  • Add dedicated repeaters
  • Add additional Inovelli switches
  • Add additional powered z-wave devices

I’m using a combination of all three methods, but every scenario is a little different so find what works best for you. If you go the repeater route it’s recommended to get at least two (depending on house size / distance). Place one repeater close to the hub first, and then the second about mid way to your furthest device (staying within range of the first).

The Ring Gen 2 repeaters are a great option. In addition to being z-wave 700, they have batteries allowing for power outage reporting.

If you haven’t already seen it check out the Hubitat guide on building a strong mesh here: https://docs.hubitat.com/index.php?title=How_to_Build_a_Solid_Z-Wave_Mesh

1 Like

Ok, added additional switch. Now the connectivity is back.

But associations don’t work.
I added Z-Wave Association Tool and created 2 associations, but it doesn’t do anything, unless I’m missing something.

Seems like the groups were applied on the Inovelli dimmer:

  • deviceType: 1
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x26,0x70,0x85,0x59,0x55,0x86,0x72,0x5A,0x73,0x32,0x98,0x9F,0x5B,0x6C,0x75,0x22,0x7A
  • associationGroup1: [01]
  • associationGroup4: [08]
  • deviceId: 1
  • associationGroup2: [08]
  • manufacturer: 798
  • associationGroup3: []

but I don’t see anything on Qubino:


  • deviceType: 1
  • inClusters: 0x5E,0x86,0x5A,0x72,0x73,0x27,0x25,0x26,0x85,0x8E,0x59,0x70
  • outClusters: 0x20,0x26
  • deviceId: 83
  • manufacturer: 345
    In Use By
  • [Pendant Switch Association Group 2 ]
  • [Pendant Switch Association Group 4 ]

I’m unsure if the association tool can be used to with Qubino devices . @EricM_Inovelli any chance you can confirm if this is possible?

@amdbuilder It will work with other brands when the Inovelli is the source device.

@curiouspasserby It looks like the security level does not match for the two devices. The Inovelli device was included with security and the Qubino was not. The type of security that was used for inclusion has to be the same for the devices to communicate with each other. If you have a C-7 then you can choose the security level during inclusion. If you have an older version you need to make sure that Z-Wave security is set to only “Locks & Garage Doors”.

@EricM_Inovelli yeah, I remember I saw a mention about different security levels not working with Associations, but I wasn’t sure if it was a bug in the driver and it was fixed or it’s actually a part of Z-Wave standard and is expected.
I have C5 Hubitat.

Thanks for giving a lead. I’ll try to re-pair it insecurely and check again.
I’m not sure if it’s possible to join Qubino securely though (it does have Z-Wave 500 series chip (Z-Wave +)). At least I don’t see anything about security there (is S2 required?): https://products.z-wavealliance.org/products/2196?selectedFrequencyId=1

@EricM_Inovelli any way on C5 I can join the dimmer/switch insecurely without changing Hubitat’s setting to “Locks & Garage Doors” as it’ll require to rejoin every z-wave device I have

@EricM_Inovelli I was able to reconnect it non-secured. Associations started to work. Thanks for the hint.

@jtronicus So one thing I don’t understand at all is why when I set “smart bulb” mode, it still completely shuts the power to the bulbs (when it shouldn’t!). I’ve seen several people also mentioned it in other threads. What’s the purpose of “smart bulb” mode when I send/press OFF it’s shutting down the power physically, but not virtually?
So I was thinking of using “Smart bulb” mode expecting that it’ll not shut down the power, but since it will, I re-wired both hot line and load into hot line on the Dimmer.

@Chris I set the all 2, 3 and 4 groups and now it’s awesome!
@jws6, so as Chris mentioned associations do work, but you’ll have to be sure that both source (dimmer) and target (bulb) were joined similarly: both secured or both not-secured.
The coolest thing associations give you is that you don’t need hub at all for them to work: they work directly via the z-wave network talking to each other.
Also all 2, 3 and 4 groups (at least in my case) should be created.
2: gives you on/off command working via HUBITAT (via dashboard, for example)
3: gives you SET LEVEL working via HUBITAT (same via dashboard, for example)
4: gives you START LEVEL CHANGE working on PHYSICAL Dimmer (apparently physically pressed on/off is treated like Start Level change and not like quick on/off)

I’m only not happy about smart bulb mode unless I misunderstand the use case

I believe smart bulb mode just changes some internal settings to increase stability when using smart bulbs (some smart bulbs do not work properly without it). It does not actually prevent you from turning off the power to the bulb, so it should be used in combination with disabling the relay.

1 Like

@jtronicus yeah, disabling the relay pretty much simply disables the LED dimmer (it’s always 100%) making it useless, so I barely see any use case with smart bulb mode + local mode disabled

I’m not sure you accurately read the thread that I was on because my dimmer to bulbs were already paired via association using Group 2 & Group 4 (I’m quite clear on how those two groups work). However, I’ve never used Group 3. I tried adding it per your suggestions, but it didn’t add any functionality to my existing setup and it definitely doesn’t update the LED strip like the rules w/ variables that I created.

Until someone can prove me wrong, I think the rules that I built are the best way to have the dimmer led strip match the dimness level of associated smart bulbs.

Try add group 3, and remove group 2…