Fan Switch Commands

Hubitat C8
firmwareMT: 122F-0201-02020106

So with the new firmware and drivers my fans switches are now working, however im having issues with changing the configuration of 1 of the 7. For what ever reason after updating the firmware/drivers The LED has turned red, and now when using the physical switch the speed defaults to low. My desire is to have the LED off and the fan Default to high. All the other switches defaulted back to the normal on/off blue LED. I’ve gone into the hubtiat settings for it and tried changing multiple settings and it doesn’t look like its responding to any of them (however it will respond to on/off/configure/initialize) Any ideas how to manually set these options?

I’ve tried changing LEd Effect All - =LED off
set speed - high
(9) Minimum level 99
(97) LED bar intensity (when on) - 0
(98) LED Bar intensity (When off) - 0

None seem to make a difference,

Current States

  • held : 1
  • internalTemp : 86°F
  • lastButton : Tap ▼
  • ledEffect : Stop All
  • level : 20
  • numberOfBindings : 0
  • numberOfButtons : 14
  • overHeat : False
  • powerSource : Neutral
  • pushed : 1
  • smartFan : Disabled
  • speed : off
  • switch : on
  • switchMode : unknown model
  • smartBulb : Disabled

Try factory resetting it. Then add it back into the network. Don’t remove it from Hubitat. Once included, then configure → all.

well that reset it back to blue and turns on at max speed, i’ll keep playing to get the led back off. Thanks a ton not sure why i didnt think of that.

Messed with it 3-5 times now and still unable to get the LED to cut off. I was able to get it back into the three speed mode but unable to make default to high speed.

I’ve been trying to set LED Effect All = 0 as well as option 97 98 to 0

Maybe im just configuring it wrong. I’ve making my settings then hitting save prefrences > configure (while blank) also tried configure with all selected with no results. However i am managing to put it in 3 speed mode, which is fine, i just need it to default to high.

State Variables

  • parameter21value : 1
  • lastCommandTime : 2024-Feb-09 9:05:38 AM
  • lastCommandSent : setParameter(258, 0, 1)
  • parameter32value : 88
  • parameter258value : 0
  • dimmingMethod : Leading Edge
  • driverDate : 2024-02-06
  • parameter33value : 0
  • parameter22value : 1
  • parameter97value : 0
  • model : unknown
  • parameter52value : 0
  • parameter259value : 1
  • fwVersion : 1.06
  • lastEventCluster : Private Cluster
  • parameter120value : 1
  • fwDate : 20240206
  • parameter98value : 0
  • parameter51value : 0
  • parameter257value : 0
  • parameter15value : 100
  • lastEventValue : 00
  • auxType : unknown model unknown
  • lastEventTime : 2024-Feb-09 9:05:38 AM
  • lastEventAttribute : 52

Did some
More testing based off another post, I can get the LED to get brighter but setting to 0 to disable resets it to default