Firmware v1.48 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)


I’ll let Eric M confirm on this one as I’m not 100% sure – but from what I gather it fixed the issue where if you dim the switch down to 0, it actually cut power to the bulb, which was an issue.

In addition, I think they were working on tweaking the LED bar to match the level at which the smart bulb was at, but if I’m reading the email correctly from the engineer, I’m not sure if this was achieved in this version.

The feature that was requested around configuring the ms delay has been added (0-900ms) where you can set the delay for multi-tap by 100ms increments.

1 Like

It is supposed to address both of these issues (which is actually caused by the same issue), but I have not verified that it is working correctly.

1 Like

Woah, the new firmware is out! Exciting times. I’m going to load it into one of my switches now and can help you with testing it if needed!

I believe I was able to successfully install the LZW31-SN_1.52_1.43.bin file through my Hubitat C-5. I’m using the ‘User’ app from Github, Z-Wave-Firmware-Updater.

Looking forward to seeing the 1.52 release notes. It successfully installed on the same switch.

New Beta release located here:

Firmware v1.52 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2) - News, Updates & Roadmap - Inovelli Community


I’m using Zwave2MQTT. It has a firmware update tool built in. Can this be used to flash the two Inovelli firmware files?

Did you mean Zwavejs22MQTT? I didnt think zwave2MQTT had a built-in firmware update tool

You’re right. I meant zwavejs2MQTT (GitHub - zwave-js/zwavejs2mqtt: Zwave to Mqtt gateway and Control Panel Web UI. Powered by Nodejs, ZwaveJs and Vue/Vuetify). I’m using their latest dev Docker image. Sorry for getting them mixed up. Their names are very similar. Here’s what I see when I browse to the control panel for zwavejs2MQTT.


1 Like

I’m wondering about this too

Looks like the latest version of Zwavejs2mqtt supports the multiple firmware files.

1 Like

Just a reminder that there is a more recent beta:

In case you all are looking for the bleeding edge :D.

1 Like

Odd - I’m getting the following error when trying to flash the bin file (Target 1): “Error while calling api beginFirmwareUpdate: Unable to extract firmware from file: Could not detect firmware format.” I’ve tried both the production and the beta files.

I believe support for .bin files was just added today ( Release v6.3.0). You may need to update your zwavejs/zwavejs2mqtt

1 Like

Wondering if there is daylight at the end of the v1.52 beta such that it will be released?

Also, there is vague mention of “bug fixes” and wondering if that would solve a v1.48 red dimmer having to have power cycled in order for it to communicate on the Z-Wave network after dropping off of it?

There will be at least a 1.53 to fine tune some of the changes in 1.52.

Can you give me more background on this? What platform and config are you seeing this on?

Good news regarding the release.

Setup is Z-Net on HomeSeer. Only 2 so far, both Red Dimmers. But it seemed very odd to have happened. Seems happy after power cycle.

1 Like

I was installing a dimmer in the new house and tried to use the config button to set it for 3-way using an aux switch. The dimmer has the neutral supplied and the aux switch was the Homeseer HS-WA100. I’m not sure what I changed because the aux switch didn’t work right so I got one of the settings wrong. I reset the switch and tried again and then it began working.

However, the interesting part was that with the wrong configuration the dimmer started to click just like the switches click when turned on and off. It did still worked to dim properly at the dimmer. This leads me to believe the dimmer has a relay in it. So, my question is why the dimmer doesn’t always use the relay to turn off the lights? When turned off, ramp down as per the settings then open the relay to turn off. This would avoid leakage current through the MOSFETS, which would both eliminate complaints of bulbs still glowing when off and save some leakage power that is making it to the bulbs.

Not sure where else to post this question. I had upgraded all the dimmers before beginning to install them so I hopefully wouldn’t have to upgrade again.

That is a good idea. The clicking is because in 3-way dumb switch mode the wiring is actually a traditional 3-way circuit. So the relay switches the output from the Aux terminal to the Line Out terminal. This isn’t needed in the other modes, but I guess it could be used to cut power to the bulbs in neutral mode.

1 Like

@EricM_Inovelli Unfortunately I’m getting the following error when I click the file link above.

Not Found

The requested URL was not found on this server.

Apache/2.4.29 (Ubuntu) Server at Port 443

1 Like