Having Trouble with fade on

Hi, I’m using the Red Dimmer Switch with EATON ceiling lights from the compatible bulbs list. I’m using the motion lighting app to turn it on, but I can’t get fading on to work. If I set fade to 3 seconds, it will be off for 3 seconds and suddenly turn on. Fading off does work so that’s weird that it turns on instantly and then fades off smoothly. I’ve tried tweaking the fade time parameter in the device setting and the fade setting in the app but nothing works. I’ve also noticed that “set level” only works from 30pct and up. Anything below is off. And also when i press the dimmer locally the fading on is so much faster than fading off.

The fact that you noticed that issue with “Set Level” is likely the key to solving your problem. Since 1-30% isn’t “on,” your lights are spending about a third of the time that they are supposed to be fading up in a state that is in fact off, which almost explains the sudden turn-ons instead of the fade up. (Really, you’d expect it to be just a quicker transition but still some transition, but I think this might help regardless.)

Check out the “Minimum level” preference in the driver, assuming you’re using Inovelli’s custom driver. (This isn’t exposed in Hubitat’s stock driver.) Alternatively, you can use the Basic Z-Wave Tool from Hubitat to just set this value manually (parameter number 5, size 1, value … whatever you want to try but probably around 30). This parameter takes values from 1-45 and adjusts the dimmer so that the lowest level, 1%, is this value instead. The regular range of 1-99 both to and from the hub/dimmer is then scaled evenly across this range, so you can use it like “normal” once you get this configured. In your case, I’d suggest starting with a value of 30 here, then seeing how that affects things. You may need to go up (or, less likely from your description, down) a little to get things to work right. Be sure to test in both directions, both up from off and down from a higher level to 1%.

1 Like

Thanks again Bert. I already tried tweaking the minimum level, but after reading your response I went back and adjusted it again in a more organized manner. I ended up getting the minimum level all the way up to 45%. The lights still look like it’s jumping 10-20%, but at least it’s getting to 1% lighting faster rather than staying dark for 1-2 sec. Still I’m surprised the lights are not actually dimmable to 5% as it says on the box. I’m returning them and i’m gonna try out another leading edge light.

Here is the best way to adjust your range. Set the min and max to 1 and 99. Operate the dimmer and make a note of what you want your max brightness to be as well as the dimmest you want the bulb. Then reset the min/max to those percentages. That will result in the dimmer adjusting your desired range to it’s 1 - 99%.

So for example, if you decide that your max should be 90% and your min 40%, after you reset to those values, the dimmers 1% is really your 40% and the dimmer’s 99% is really your 90%. Doing this re-maps that full dimming range to the percentages you desire.

This kind of dovetails into @BertABCD1234 's explanation about the wasted time turning on.

Of course, as you mentioned, a different bulb may perform better, but you should still re-map the range as described above.


So that’s what my parameters look like now adjusted to 45-99. Since I only brighten to 75% anyways i’m gonna try lowering the max to 75 to see if i get an even smoother result. But are you saying there’s a button/command that i click on to make it ‘reset/remapped’ to 1-99 or is it already remapped right now? Because i do see a reset button on the device page.

As soon as you hit “Save Preferences” on the device page, the new configuration parameters will be sent to the dimmer, so you don’t need to do anything extra there to make sure they take effect. The “reset” button you see is to reset the power/energy-metering statistics.

Do note that some people have reported that if you adjust the maximum level down too much, then the jump between each remaining percentage may seem a bit “rougher” (more noticeable) than it were if a wider range of values were available. I suppose the reasoning behind that makes sense, with jumps of 1 from 1-99 now being scaled over a narrower “real” range. Anyway, if dimming above a certain percent doesn’t actually cause problems, you may want to consider leaving that at 99 if you notice anything like this. (There is also a parameter/preference you can adjust for the default physical “on” level, which may help so you don’t have to constantly fiddle with the paddle each time you turn the light on — it can just go directly there with one tap.)

So i tried configuring the minimum again with new HALO brand lights that says can be dimmed with leading and trailing edge dimmers. I was able to get the minimum setting down to 31, which is an improvement from 45 on the other lights i returned. The fade on is not quite perfect but it’s noticeably better.
Something i noticed when testing out the minimum is that the lights cut out at 31, but when i try to increase the level again, it won’t turn on until i set level somewhere around 40. But once it’s on, it can be decreased to 32. I’m not sure if this is still an issue with the light hardware, the dimmer or the way i wired the dimmer, but I think the smoothness of the fade is good enough for me to call it a day.