How can I control a Zigbee Lightbulb with a Black Switch in Hubitat

I have an outdoor zigbee flood light that I want to control from an Innovelli Switch(LZW30)

After a bunch of research of how to do this, what I think needs to happen is I need to configure the switch so power is always going to the load(the bulb). Then I need to link/sync/rule so when someone presses the switch “on” up, the bulb is told to turn on… and then the opposite to turn off…

I thought I would be able to do this with the Hubitat rules engine but my switch does not show up inte button devices… I finally figured out/realized that the black switches apparently don’t expose “button events” (is this accurate?)

I have a number of red switches and black switches and I guess I could swap switches out… I never understood the difference between black and red until now…

Question 1 – Is there a way to control a zigbee switch with a black switch?

Question 2 – Am I approaching this right – disable the local control and use the rules engine to look for button events?

Only red switches present scene events, you are correct.

So you have 2 options:

  1. Control the power to the bulb (pretty useless IMO)
  2. Swap out for a red switch/dimmer.

Did you happen to try using “Physical Switch” instead of a button device?

Does this switch control anything other than the outdoor flood light?

Maybe we can wire constant line to the bulbs and use rule machine to turn on/off lights via state changes vs scenes.

E.g. I have a rule when I press up on my basement stair light, it turns on my stair lights and basement lights based on the switch turning on, not by scene control. Same for turning off.

@kreene1987 Thanks… I wanted to make sure I wasn’t overlooking something dumb… I will swap out the switches.

@Byarnell05 I have to keep the load powered because I have a camera plugged into the fixture with the flood light.

Next Question – how do I make sure that the load stayed powered? If I disable local control, do the button events still fire?

I thought when I installed all my switches, I remember a setting to tell the switch the load was a smart bulb so it would maintain power to load but dang if I cant see that anymore… i don’t know if it was an old firmware or new firmware or what… I have like 50 devices and maybe Im getting old… or maybe it was a smartthings thing.

1 option for now, soon to be 2.

Disable local control disables the internal relay from local button pushes and sets load at 100%. Coupled with Smart bulb mode the voltage should remain 100% always. Only problem is the LED bar stays on 100% all the time.

In the next beta firmware (fingers crossed) they should be further improving the Smart Bulb Mode so that even a single toggle down will send a scene and turn the LED bar into “off” state, but the load will remain powered 100%.

So Disable Local Control (8 config presses fast) is your best bet for now.

Yes, you would need to disable local control and turn on smart bulb mode if your firmware has it. I would then test by watching the device for events when you push up or down. At this point all you need is for hubitat to notice events, if it does then you should be able to have hubitat action off of those events.