Hubitat C-7 not receiving events

I have installed five Red dimmers so far from my 10-pack and inclusion was no problem. Things seemed to be going ok until I tried setting up some automations/notifications in my Hubitat C-7. While the dimmers all respond to commands and notifications coming from my hub, it appears that none of the local button presses is ever received by my HE. I am mainly seeing lastEvent in the event log, with some power reporting. No presses. Other non-Inovelli devices are working just fine with Hubitat rule machine.

Yet another clue is that, when I try to control the dimmers via Alexa, the commands do work but a few seconds later Alexa complains about not having received a response from the device.

All my dimmers are wired to neutral and so far I’ve only installed simple single-pole configurations. I’ve been trying all sorts of things for the past week and read countless articles but no luck. Any help would be greatly appreciated!

FYI, I have installed and have set my dimmers to use the latest Inovelli driver and they are on firmware 1.47. (I tried updating to the 1.48 Beta via the bcopeland driver but could only get the “sleepy device” error… which is just another case of HE not receiving messages from my dimmers.) Hubitat is running on 2.2.3.148.

Cheers,
Steve

Hi @Samus,

I’m not using my new C-7, Yet.

If you are using the Inovelli driver, Make sure the “Enable Informational Logging” switch is on and that you have set the “Disable Info Logging” field to 0.

On my C-4, if this is disabled, I see what you are seeing

Thanks for the suggestion @Ma2J,

I had enabled both debug and info logging and both disable timers were set to 0. Right now the two main problems are Alexa complaining about not receiving a response (which I can mitigate by setting the Hubitat to respond immediately without waiting for a response from the bulb… but that’s not reliable long term) and the main issue that I can’t have automations/scenes triggered by my switches (which was the whole point of getting them).

I am going to reset my hub as this seems most likely to be a weird interaction between the Hubitat (specifically the C-7) and the Inovelli switches.

Did this work? I have held off migrating to the C-7 for now. I changed A LOT of stuff this year and can’t afford to have my WAF go into negative territory. :crazy_face:

So far I’ve only done a soft reset and restore of my backup, which unsurprisingly didn’t work but it’s all I’ve had time for so far. Will post an update once I’ve gone through a hard reset and setup from scratch.

Things seemed to be working much better after I did a hard reset. I started receiving scene presses on my C-7. Then, after adding only a few of my switches, I was no longer able to include/exclude anything. This seemed to be the C-7 inclusion issue addressed in firmware 1.48, so I did another hard reset and immediately updated the firmware on all of my switches (except one, which won’t stop showing “Please wake up your sleepy device”… but I’m sure I can eventually get that sorted).

I haven’t yet switched to the Inovelli drivers or tried scenes since the firmware update, so I’ll report back later with more info.

Thanks for the updates!