Ilumin RGBW bulb unable to change colors - SmartThings

I have the two iLumin RGBW bulbs that came with my Black Friday deal. I have tried multiple times to get these bulbs working properly with my ST hub. Inovelli has even replaced the bulbs a couple of times to try to get them working.

What is happening is that I am able to include the bulbs with ST and then I can adjust color temp and dim and brighten. But when I try to change colors by touching the color palate icon, the bulbs turn off and become unresponsive. I then have to exclude then reinclude the bulbs but, once again, when I try to change the color, the bulb just turns off and becomes unresponsive. I am using a pull chain lamp to install the bulbs and not on any sort of smart switch.

Any ideas what might be happening?

Which version of ST Hub do you have? I had the ST Link on my NVIDIA Shield and had all sorts of problems.

Did you install them in classic or the new smartthings app?

I believe I am using the classic app. The hub is version 2, I believe.

Have you installed the handler yet?

I have lots of these bulbs and they installed with several variations of handlers for some reason. I had to do go into each of them to make certain they had the correct handlers. Once installed some of them still didn’t work and required a factory reset.

Factory Reset:
Click on bulb (in app, because clicking or tapping on actual bulb is like fixing an antenna issue by hitting the tv)
and then click the gear icon. Then scroll to the bottom and click, “Remove” and then turn the bulb off (cut power) and then turn it back on. It should blink twice and then a third time to signify that it removed properly.

If it doesn’t remove, click, “Force Remove” and ignore the warnings.

Once both are removed, please do the following:

  • Click on the Menu and select, “Hub is Online”
  • Then click, “Z-Wave Utilities” and then, “General Device Exclusion”
  • Turn the power off to the bulb and then click “Remove” - once the Hub is excluding, turn the power back on - the bulb should blink twice and then a third time if successful (the app will also tell you it removed properly).
  • Now, turn the bulb off again and go to, “My Home” and click the (+) at the top right to add the bulb.
  • Once the hub is searching for the bulb, turn the power back on and it should blink twice and then a third time to confirm.


Totally forgot to mention a nifty quirk (learned the hard way)

If you have to reset a bulb, make sure its the ONLY smart bulb in the fixture or it might reset something else. Also I found the bulbs worked better if I paired one, removed and place next one, paired then removed. Systematic and tedious but worked without issues I had noticed using other methods.

I do have the handler installed and I have tried some of those steps, but not all of them. I will give it try next chance I get. Thanks!

I tried all the steps you painstakingly outlined for me and was able to exclude and re-include the bulb but, when it got included on ST it came up as a generic smart dimmer switch, which has happened to me before. I went to ST IDE and edited it to be the Inovelli multi-color bulb. When I went back to the ST classic app, I was able to change brightness and color temp but, when I tried to change colors, nothing happened. It would not change colors. Honestly, these bulbs are behaving more like the tunable white bulbs than the multi-color bulbs. At least the bulb did not turn off and become unresponsive like it has before.

Thank you so much for your help. I am pulling my hair out (at least I have some to pull out) in frustration with these bulbs.

I am really wondering is something wrong with the Inovelli supplied device handler or is there some setting I am missing to get these to work? I know the first two bulbs I got did initially work and I was able to change colors. But once they turned off and become unresponsive the first time I used them, no bulbs I have tried since then have worked.

I dont use ST, but I did notice something in my own setup (openZwave) that might help.

It looks to me like the color temperature and the bulb color value are all part of the same command under the hood, and are sent in the format RRGGBBWWCW (Reg, Green, Blue, Warm White, Cold White). If I set the light to red, it will send FF00000000. If I set it to Warm White, it will send 000000FF00. So far, so good.

However, if I try to send a command for both red AND Warm White (FF0000FF00), the color temperature has precedence over the actual color, and the light will remain Warm White.

I suspect either a configuration or device handler issue. It sounds like you have both a color temperature slider and a separate color wheel on your interface, but if ST is sending both values as part of the same command, you will always end up with a white light.

Is there some sort of log in ST that tracks what commands are sent to the bulb?

This behavior you’re describing seems to be exactly what is happening to me. The bulb seems to default to a warm white but I have been changing that (2700K to 3000K) to test it then trying to change the color and the bulb remains white.

Maybe I should try changing the bulb to a colder white then try the color change?

For me, it didnt matter what the color temperature was. If I tried sending an RGB color AND a color temperature at the same time, the color temperature always won and I would end up with a white light.

Red Green Blue Warm White Cold White Resulting color
FF 00 00 00 00 Red
00 FF 00 00 00 Green
00 00 FF 00 00 Blue
00 00 00 FF 00 Warm White
00 00 00 00 FF Cold White
00 00 00 80 80 Warm-ish White
FF 00 00 80 80 Warm-ish White
FF 00 00 00 FF Cold White

Essentially, if the Warm White or cold White channels are anything other than 0, you end up with a white light.

Interesting. That does sound like a problem with the device handler. To set the warm and cold to 0, would I just set the slider to 0?

Unfortunately, since I dont use SmartThings, I am not really sure what setting the slider to 0 would do. I havent seen any other posts in this forum of people with the same issues as you though. It makes me wonder if you somehow have the wrong device handler installed.

It could be the wrong device handler although I’m pretty sure I installed the one provided by inovelli. I guess it couldn’t hurt to just reinstall the device handler.

I found something on a SmartThings forum post that suggests there are logs available. It might be worth checking some of these out to see if it points you in the right direction.

Device logs: > My Devices > (Choose a device ie Switch1) > List Events
Want to see what your devices are doing and why? Then this is your stop. These entries are historical up to 7 days
DEVICE /physical: came from physical contact
APP_COMMAND: came from an app

There is a updated DH for the colour bulb also…

Thanks, Scott. I will grab the updated DH. And I will check those logs to see if they say anything useful.

I see there is a whole other “def” section at the bottom of the DH script that defines temps and colors that my DH doesn’t have. Maybe that will do the trick.

1 Like

That DH was created for another customer to see if that fixes their issues. It might work for you and if it does let me know so I can let @EricM_Inovelli know this.

Ummmm… @EricM_Inovelli is the new handler supposed to change all bulbs with that handler to same color in the house? Also the new handler shows up as a switch in SmartThings but operates as a bulb but somehow changing one bulb changed all of them.

This is actually a version of the handler created by @bcopeland. Want to make sure he gets credit for the work he did. We are having some users test it to see how it does on SmartThings.

1 Like

@EricM_Inovelli and @Eric_Inovelli It does some CRAZY things.

-On a light fixture with a non-inovelli switch, changing “bulb 1”, changes all bulbs in same fixture.

-Changing colors on an associated inovelli red dimmer v2 causes some of the bulbs to flicker.

-BUT on a Red v2 On/Off switch it is a superior handler and all bulbs operate as intended in same fixture.

On a related note, 4 of my dimmers, 3 attached to Inovelli RGBW bulbs all have TONS of issues and as of last night, one dimmer was bricked in an “Offline” but on state, unable to factory reset and it stays lit up. Breaker reset seems to also not do anything. Before the brick, the other 3 all have a lot of issues with RGBW bulbs, couldn’t go below 30 on dim before flicker light show (with relay disabled), with relay enabled they dim poorly but also make the buzz. Disabled relay also makes the led on switch just a pretty light. The physical paddle on switch works, some times but hit and miss. About to send them all back since we have none of the issues with on/off v2.