Improving WAF - Resetting LED Lights to default soft white

Hey all -
Been installing my Blues thoroughout the house and am absolutely loving the flexibility of them.

I am hoping someone can give me the most wife-friendly way to have Smart-Bulb-Mode-Connected-Hue Lights. Details:

  • I have a number of rooms where I have my Blue switch set to Smart Bulb mode with a number of Hue Lights bound to the switch
  • At night, I have my first floor lights turn blue via a Home Assistant Scene and then all turn off at 1:00 AM.
  • When my wife comes down in the morning, she goes to turn on the kitchen lights and…they remain blue from the night before, thereby pissing off my wife.

I know I could write another scene in HA to turn the lights back on with a Soft White color scheme and then immediately turn them off at 1:01 AM, but I’m questioning if that’s the best way to do it.

Any suggestions?


Are you using zigbee2mqtt? If so, the best way to do this is to “pre-stage” them to the desired color (soft white) using ZigBee scenes.

To do this, simply add a scene to the group of bulbs without including the “state” attribute. This will adjust the bulbs’ colors regardless of whether they’re currently on or off. The next time the switch is used, the bulbs will already be at the correct color.

This can be extremely powerful for things like circadian lighting: you can push scenes to ALL of your bulbs that adjust their color temp throughout the day, but without impacting their state.

This can probably be accomplished in ZHA as well, I’m just not as familiar with it.

Thanks, Sir. I had the scene setup in Z2M but didn’t remove the state parameter from it.

Will give that a try.