Inovelli LZW31-SN + Add-on not working properly

I picked up a single Red Series dimmer and two GE 12723 to test a 3-way setup.
Switch is configured in Home Assistant as Config Parameter 21: neutral wire and 22: 3-way momentary.

I tried both GE add-on switches and they behave the same:

The Inovelli works properly, but the add-ons can only dim or turn off the light because regardless of whether I use the top or bottom half of the paddle, it always functions as the bottom half. I cannot use the aux switch to turn on or increase brightness.

I am using the neutral wire setup on page 10 of wiring guide: 3-Way Installation (Line/Load Separate Boxes) - Option #1, Inovelli Smart Switch + Auxiliary (Add-On) Switch.

Any ideas?


I dont have any 3-way switches, so I havent experienced any issues, but I think some other users with issues had good luck with changing parameters 21 and 22, and then changing them back.

I recommend try changing Parameter 21 to Non-Neutral, then change it back. Then change Parameter 22 to Load Only, then change it back.


You are the best. After reading your message I recalled reading that elsewhere on the forum. I had already tried the changing Parameter 22 to each of the options, but I had never touched Parameter 21. I probably could have just toggled 21 but I changed both in order as you said, and that did it! I am very happy, I can now finally place an order for another 20 dimmers. Thanks again.

1 Like

I had the same issues. It took some searching around online before finding the requirement to change the parameters in the device handler. Even after finding the settings, the new Smartthings app wouldn’t allow changes to the parameters that controlled neutral and 3 way switch.The edit link was there but nothing happens. Had to reload the classic app in order to change them.

Unless I missed this completely, Inovelli’s instructions don’t refer to these settings in their setup for 3 way use. It might have saved a lot of time and energy if this was more obvious.

1 Like