Installing LZW31 dimmer to Home Assistant

I am running Home Assistant (21.6.6) on a Raspberry Pi.
Yesterday, I was able to add a node (3) a Inovelli LZW31-SN Red-Series Dimmer.

For some reasons, it stop responding this morning. I tried to add the node again, without success. I even factory reset the unit (holding the config button for 20 seconds). I cannot add the node.
ZWAVE JS (config) indicate that I have 2 devices my Z-Stick Gen5 (node status : Alive; node ready; YES) and Node 3 (node status : DEAD and node ready : NO.

Any suggestion how to remove this node and reinstalled my switch
I have 5 more Inovelli switches to migrate to Home Assistant

May get more help in the HA forums. I use HA but I run ZwaveJS2MQTT. I’d think if you factory rest the unit, you should be able to add it again. When you factory reset, are you waiting for the light to turn red? I’ve found its not always 20 seconds on the dot

Is this device the closest device to your z-wave stick? How far is the device from the stick?

In general, make sure you start with the device(s) nearest to the stick and work your way out. You can also get more real-time help in the Z-Wave channel on the Home Assistant Discord chat.

Sounds like you did it right, but z-wave really doesn’t get reliable meshing going until you get about 4 devices up and running.

I’d recommend adding the other nodes and letting us know how it goes. I had the same issues with 1-2 devices where they weren’t incredibly reliable.

Not, it is not the closest. I will try with on other one.
Thanks for the suggestion