Is mixed firmware OK?

I used to be able to upgrade the firmware of my red and black dimmers and my fan + lights without any problems. But now I’m having great difficulty doing so. I’m using a Hubitat C7 hub, currently on, but this has been going on for many months. I recently was having problems with some switches where I’m having to air gap them to get them to work again, so I tried to upgrade the firmware for one of my red dimmers from 1.48/1.41 to 1.61/1.45. Although it took over 40 minutes I was able to upgrade “0” from 1.48 to 1.65. However, when I went to upgrade “1” to 1.45 it started out running much, much faster, but then hung at 66%. After aborting I tried to run the upgrade again but it either wouldn’t start or would hang at 1% or 2%. I tried using both their Device Firmware Updater app and going into the device itself and switching the driver to the Z-Wave Firmware Updater driver and doing it that way. Neither way worked.

I can’t use a Z-Wave stick as I only have a Mac.

So, it seems I’m stuck on having “0” at 1.61 and “1” at 1.41.

Is that harmful at all?

Anyone have any other suggestions?