Issue (I believe confirmed) with Hubitat version and Inovelli Button 7 (Config/"Favorite") button!

I got my Hubitat C7 hub back in February. Since then I have installed 18 Red Series dimmers (LZW31-SN) )( “RD”), Five Black Series on/off switches (LZW30) and 5 Red Series Fan/Lights (LZW36).

While I have had instances of button pushes not working for a brief period of time they all have been working for the most part. However, something strange started happening the other day after I installed Hubitat’s hub software version and a button 7 push on my Red dimmers.

I have an Alexa Good Night routine that turns off my TV, turns off some other lights and then turns my Outer Hall light to 35%. It’s been working for about the 1 week - 10 days since I created that routine. Yesterday, suddenly, everything worked except the Outer Hall light didn’t turn on. Likewise, I have an Alexa Good Morning routine that also turns on this light to 35%, turns on the lights the good night routine turns off, and turns on the tv. I also did that one earlier yesterday morning and it worked fine.

I also have a Hubitat rule to turn it on to 35% with a button 7 push which was working fine. In fact, I used it yesterday morning. When the Good Night routine didn’t turn on this light I tried physically pushing button 7. That didn’t work either. After turning the light on and off with a physical button 1 push/held several times it suddenly started working again.

Then when I went to bed last night I was glad to see that the good night routine worked and that light came on to 35% as it was supposed to. However, I have 2 Red dimmers in my bathroom that are supposed to do the same thing with a button 7 push. Neither one worked, but the button 1 push/held (i.e. pushing the paddle up or down one time) worked fine. I then tried pushing button 7 on two RDs that can turn a light on in my closet. I got the same results: i.e. button 7 didn’t work but turning them on/off from the paddle worked fine. I then tried a switch in another hallway, the switch for my kitchen and the switch for my dinning room. All of them reacted the exact same way. So that was 7 switches all turning on and off from the main paddle but not from button 7. If it had been one, or maybe even two of them, I could have thought it was the physical switch but 7 seems unlikely in the extreme. Plus, after a few minutes they all started working again with button 7. And, as a last factor, that good night routine is supposed to turn the Outer Hall light off after 2 minutes, but it didn’t. I had to physically push the paddle down to turn it off.

The only thing that has changed is that I installed Hubitat’s hub update to version just the other day. So it seems something isn’t communicating properly between the 2 with this release and a button 7 push on the Red dimmers.

Just FYI, I also posted this on the Hubitat site as I think it is their issue mostly, but also wanted to give anyone here a head’s up in case they have similar issues.

Tried turning on all logging for one of the applicable switches and watching the logs to see if Hubitat sees the button 7 push?

I got this from shawnx1 on Hubitat

So button 7 is working now ? so many buttons just want to be sure
Reason I ask is because when I updated to 2.2.6…I had to go into each
Invovelli device I have and hit config to get my buttons to work.

I answered him:
Yes, it was totally and only button 7. So I went and tried all my other RDs and sure enough button 7 wasn’t working at first on any of them. I turned the lights on/off with the paddle and pushed 7 a few times and it started working. I’m not sure if it was the multiple pushes or just X amount of time elapsed from when I first pushed them until it started to work again. I do want to add that I have not created any rules or anything like that using modes, so the time of day shouldn’t matter.

So it seems there was absolutely something with that did it.

03/31/2021 Update:
So I suddenly started getting the problem with the button 7 push not working again last night around midnight on my 2 bathroom switches. A button 1 push or held worked just fine. (Turning the lights on and off). It was too late to try other switches or go get the logs.

This morning and just now (about 11:54 am 03/31/2021) then were working just fine.
I went into Past Logs but it only went back to about 9;30 am. At the bottom it says it is loading past logs, but nothing more came up. (I’m not sure if there is a way to get the past log to go further back than about 2 hours).

Just so I could post some logs in the hopes it would help I went and pushed button 7, then button 1 held (off), button 1 pushed (on) and then a button 1 held again. But, this was after I upgraded to

Here is the 11:54 am log:

Not sure where to respond now that I’ve seen it (and responded) in both places, but since I saw it here first, maybe I’ll try here. :rofl:

It’s not clear to me from the logs since Inovelli’s driver, which you appear to be using, doesn’t quite follow Hubitat convention, but I’m not seeing event/info/descriptionText logging (which should show when actual button events get created) in there at all. It looks like if you keep their “Enable informational logging” setting enabled, however, you should see them. I don’t see them at all for any event above.

But … I do see a config button push. That last line (first chronologically) shows the config button, which you can tell in the logs by looking for keyAttributes: 0 and sceneNumber: 3. If you see that in debug logging but fail to see an event (or in general, possibly if you see some CentralSceneNotification that gets skipped), there could be a problem on the driver or hub side. But if you don’t see anything in the logs at all when you press the buttons (and have at least debug logging enabled), then the hub thinks there is no Z-Wave command coming in in the first place, so the problem likely lies elsewhere.

All of mine are working fine for me on and have been on all 2.2.6.x builds, so I’m not sure what could be happening for you. If you believe it’s 2.2.6-related, you could try rolling back to 2.2.5 via the Diagnostic Tool to see if that helps.

It’s size-based, not time-based. So, the best way to see more logs is to turn off logging for devices that you don’t care about (this is why stock Hubitat drivers automatically disable debug logging after 30 minutes, but many community ones may not; this does not affect info/descriptionText logging, which generally shows events and may be more helpful, but some people also prefer to manually turn these off, and you might want to if any devices generate a lot of events that might be getting in your way here). Good luck!

Thank you for the detailed response. So as I understand it, sceneNumber: 3 is what Inovelli calls button 7, i.e. the Config/Favorite button.

Also, I have a question that may relate to this. When I pushed the config button on another device this afternoon it took a long time to turn on - but it did eventually turn on. I’m not sure how long, but long enough that I had started worrying that it wasn’t going to turn on. I then turned the light off and a few seconds later pushed the config button again. While there was still a noticeable delay, it was much faster than the first time. (BTW, I can’t turn Param 51 on as I am doing multiple tap scenes for these switches).

Is it possible that the Inovelli switches are going to sleep or something like that or Hubitat goes to sleep? If so, I’m wondering if it is possible that I just didn’t wait long enough (though such a long wait would be unacceptable). It seems a bit strange to me, since the hub and the switch are both powered all of the time. (I have a neutral wire on all the switches). But if so, is there a way to keep them awake?

BTW, as I’m now on .133 let’s see if that might have fixed it too. I’d rather try going forward instead of backwards for firmware since I know other bugs often also get fixed in each release.

All sceneNumber: 3 commands do correspond to the config button, as far as I can see, though ultimately the exact event is a combination of keyAttribute and sceneNumber.

The Inovelli devices shouldn’t be going to sleep; they are line-powered Z-Wave devices and, as such, should always be awake. The hub shouldn’t either, though there have been Z-Wave bugs in the past that have been fixed (the 700-series controller it’s using is pretty new, and the early days were…rough). I suppose it’s worth looking into whether you have general hub problems at the same time or if it’s really a switch/dimmer-specific problem, but that’s probably less likely (App Stats and Driver Stats may tell you something helpful about hub load history, but you’ll also get a warning from the hub itself as of recent firmware versions if it doesn’t like what’s happening).

I’m on on .133 yet but I’m going to update momentarily. I don’t see any Z-Wave fixes, but I agree that it’s unlikely to hurt. :smiley: (But if you do think the change is 2.2.6-related, going back to 2.2.5 — restoring a matching database if you’ve added any new 2.2.6 features like Basic Rules since then — really seems like the only way to test that theory.)

The switches were working last night, but then again, I went to bed about 10 pm instead of my usually 11:30 to 12:30. I’m not on so we’ll see.

This might help to graphically explain scene numbers:


This is on Node Red.

First it takes the input and says which BUTTON is it (sceneNumber in Hubitat?): Down is 1, Up is 2, config is 3.
Then, it checks which scene or event was passed (might be keyAttribute in Hubitat), was it a pressed once (1) pressed twice (2), etc.

Each of these align with a trigger that can then be used to do different things. Hopefully that helps if there was any confusion or future readers.