Issues with two Red Dimmers

Hello everyone,
I’m having issues with two of my Red Dimmer switches. I’m using Hubitat C7 for my hub.

One just don’t respond to the pedal presses but does sort of responds to config button and commands from the hub. I have configured to toggle the light using config button for now. I tried to remove it from the network and reset it to factory default, but it wouldn’t go in to exclude mode.

Second one, works just fine but not from the aux switch. It was working just fine before, not sure what happened. I’m using IInovelli aux switch and when I press it, I can hear the relay clicking inside of the actual dimmer. I would have to press the ON couple of times to turn the light on and when it turns on, its acts as if its an On/OFF switch and not the dimmer.

Anyone else have had any issues like this? I tried to update the firmware and that didn’t help.

Local protection wasn’t turned on by accident was it? Press config button 8x and watch for color flash. Then try paddles again.