Light Strip and Bulb driver not setting color temp/level

I have been having an issue after updating my hubitat to 2.2.8. All of my rules that set a bulb or led strip by using the setcolortemperature command return an error in the logs. When researching this issue I found this post: How to support the new setColorTemperature multi parameter command in user drivers - Community Drivers - Hubitat

It seems that both drivers for the lzw45 and lzw42 are producing this error. I atempted setting one of my lzw42s to 2700k, level 100, with a transition of 0 seconds straight from the device page and it produces that error. I then switched the driver to the built in lzw42 driver and tried it again and it worked properly.

Any chance we could get the drivers updated to support this change?

1 Like

You probably need to update again. The release had ColorTemp bugs.
Make sure you are running or greater…

Already running, I have reached out on their forum to see if that fix is related to this issue.

Got a response from the Hubitat team and they confirmed that the built in drivers have been fixed but community or manufacturer drivers will still need to be updated to fix this issue.

@EricM_Inovelli When you get a chance, could you look into this?

While Inovelli needs to update their drivers to support Hubitat’s new optionally-three-parameter setColorTemperature() command, in the meantime you can work around this problem by using only the “classic” one-parameter command. Or at least, you might be able to, depending on what app you’re using to automate these commands. The Scenes app was just updated to use this updated command over separate setColorTemperature() and setLevel() commands in 2.2.8, so that is why more people are noticing the issue now (the new command was added in 2.2.6 but not used anywhere in stock apps yet).

So, if you’re using a Scene, you’re out of luck. But if you’re using a rule, you can do a “Set dimmer” (setLevel()) action and do the “Set Color Temperature” separately, without a level (I assume Rule 5.0 uses the new command; Rule 4.1 was probably left-as is, but either is doable in any version regardless). If you’re using a custom app, I don’t think many have caught on to this yet but it could be easily modified if needed; stock apps besides Rules may or may not also have workarounds.

Or you can wait for the driver update, of course. :smiley:


Thanks for the tip! Had to do some digging before I realized you meant running a custom command to get separate setcolortemperature and setlevel commands. Luckily I only have a few to alter to get working again so this will suffice in the mean time.

FYI, just got a message back on the Hubitat community and the issue will be addressed in the upcoming “hotfix”.

1 Like

Thanks for bringing attention to this. I’ll work on adding the extra parameters to this command in the Hubitat drivers.

1 Like

There’s an issue with Hubitat’s built-in driver for the LZW42 if you use more than one parameter with setColorTemperature(), and that will be fixed in the next hotfix; but the above is using Inovelli’s custom driver, which they will have to address themselves (and are, it appears — thanks! :smiley:). There was also an unrelated issue with the Scenes app where it wasn’t even calling the correct command at all (typo, it looked like), but that was fixed already. Lots of CT-related issues with the recent updates to the capability and changes to built-in apps, it appears!

That works! I think you can use the “standard” rule/button actions “Set dimmer” (which calls setLevel()) and “Set color temperature” without a level (just the CT, which should call the one-parameter setColorTemperature()) — but if you use the custom commands, you know exactly what’s happening, so it’s less of a guess, just more work to set up. Glad you got it figured out!