LZW30-SN not reporting button presses

One of my Red Series Switches will not report button press to Hubitat. I discovered this when I was trying to setup a rule to activate with button press of the configuration button (7).

Any ideas of ways this can be resolved? Could it be a physical issue with the switch?

I was on firmware 1.20 when I discovered the issue, and was able to upgrade it to 1.22. The issue remains.

My investigation revealed:

  • The switch will not report status (on/off) or button press to the device page in Hubitat
  • I am able to control the switch with Hubitat (on/off) but sending a virtual button press (ex.: 7) doesn’t show on the device page in Hubitat nor does it activate a linked rule
  • Energy or Power do not seem to update either
  • Tried sending a “Configure” and “Reset” command via the device page in Hubitat - no change
  • When I do a “Refresh” in Hubitat, the status gets updated in the device page (on or off)
  • I tried using the Hubitat built-in driver and also the latest version of the Inovelli supplied driver - no difference
  • I tried pulling the air gap - no change

I have many of those switches and the others respond correctly (same firmware and driver).

Any other ideas?

One possibility is that the switch did not include correctly. I’m not on Hubitat, so I don’t know how to check to confirm. You might want to factory reset and try including again.

I had thought about that but held off on it because of the time it will take to set the switch up again in Hubitat - but I agree, this is a good next step. Will give it a try and report back.

Not sure if this will help to check with Hubitat or not, but when this happens in SmartThings, the raw description isn’t correct. It will contain 0’s where there should be non-zero data.


Thanks @Bry - The switch reset (Holding the config button for more than 20 seconds, followed by the light going red and blinking 3 times) did the trick!

1 Like

Great! Glad you got it going!!!

1 Like