LZW31-SN - Cannot see mutli tap options in Hubitat

Hello. I have gone through previous posts about scenario’s similar to mine but cant see what the solutions are.

I have just installed new Inovelli red series dimmers and switches - gen 2. My dimmers are LZW31-SN. As explained in this community, I have installed the inovelli handler and the child handler. However, after doing that, while I see all the updated parameters on the device configuration, I do not have the multi tap button options under the device commands and therefore am unable to attach scenes I have created to the multi tap options through hubitat - can someone point me in the right direction as to what I am missing.

As a note, and will be seen in screen shots below, for my switches it does show the inovelli child handler. But for the dimmers, it does not = it shows generic and I cant change it. Maybe that’s part of the problem I dont know

Thanks in advance for the help.

Hey @alexko1 – let’s see if I can help a bit and sorry for the frustration!

Can you do me a quick favor and post the following data for the switches that are having this issue?

More specifically, I’m looking for the deviceType #

You will set these multi tap options under rule machine or Button Controller found under the Apps page.

1 Like

Is this what you are looking for

the problem when I was going[quote=“harjms, post:3, topic:6720, full:true”]

You will set these multi tap options under rule machine or Button Controller found under the Apps page.

to use rule machine was that as you see under the first post, the various button numbers (ie how many times you tap) is not available under the commands of the device

I’m not tracking. My button taps do not show under the Device configuration at all from RM. I’m not at home right now to screen shot, so I’ll circle back this afternoon.

Thanks @harjms. Appreciate it. I see tones of screen shots from others who show them so assumed something was wrong on my end.

@Eric_Inovelli I noticed your screen print shows devicetype 3 and mine show 1 from what I sent you - why would that be and is that the problem?

Nope, that’s great news actually :slight_smile:

I was just checking to see if you had the Red or Black Series (I know you mentioned Red, but you’d be surprised how often this happens). This is what I typically look for when diagnosing this problem initially:

mfr:031E prod:0001 model:0001 - Dimmer Red Series
mfr:031E prod:0002 model:0001 - Switch Red Series
mfr:031E prod:0003 model:0001 - Dimmer Black Series
mfr:031E prod:0004 model:0001 - Switch Black Series

So, 1 = Dimmer Red Series, 2 = On/Off Red Series, 3 = Dimmer Black Series (which is what I took a screenshot of), 4 = On/Off Black Series

To set up your scenes, here’s a KB Article that may help. I’m not as well versed with Hubitat as I should be around the more advanced features such as the device configuration you mention, but this article should help if you are wanting to setup a scene:

so followed the instructions and in step 4 of the document, the option toprefill and see all the button commands does not exist for me. screen shot below that you can compare to the step 3 in the document.

I can manually just enter in a button number and push or held but I do not get the multiple command listing that is present in this document. Which ties to the fact I believe that I am not showing all the button options under the commands of the button in the device view.

So I can manually enter it it appears and I tried and it worked, but display of button commands is not present. Not sure why

Here is what the screen is supposed to look like

Here is what mine looks like

so maybe this is a hubitat issue not sure. I think I can manually work around it so maybe not a bit deal but it doesnt appear to be displaying the way it should

Did you install button controller from the Apps list?

Your photo looks like rule machine and not button controller.

rule machine

I think the screenshot of “Game room Scenes” is in fact the button controller menu and not rule machine. I’ll double check; however, your rule machine is right. You identify push, held, released and which number (taps) for what you’re setting up. This looks like as designed.

@alexko1 - Confirmed. This is from the Button Controller App.

1 Like

ok that makes more sense then

Thank you for checking for me.

Appreciate the help

1 Like

This is how to do it with Simple Automation rules. You have to remember that the double, triple, 4x, etc. clicks are considered buttons.

Thank you. Appreciate the help.

1 Like