LZW31-SN + GE 46199 Add-On Switch (2nd Gen)

I have now installed two LZW31-SN switches with GE 46199 Add-On Switches in two different 3-way locations. They are functioning the exact same.

The Inovelli dimmer functions perfectly. I set Parameter 22 to 2 on both. The Add-On Switch “sometimes” works. If I pull the air gap on the Inovelli dimmer, the add-on switch works once, then maybe works again? Then I can’t figure out how it works again, but maybe one out of ten times it will do as I expect.

Are the LZW31-SN’s supposed to work with the GE 46199 or should I have ordered the first gen ones?

@jrsquared What hub you using? I had similar issue with Aux switch when my 3 way momentary wasn’t setup correctly. Once I made that change on the hub it’s worked perfectly since then. I’m using these though: https://smile.amazon.com/GE-Bluetooth-Wireless-STANDALONE-12723/dp/B07X84WY5C/ref=mp_s_a_1_3?keywords=ge%2Baddon%2Bswitch%2Bz-wave&qid=1578464076&sprefix=ge%2Baddon&sr=8-3&th=1&psc=1

1st and 2nd gen mixture.

I’m using Home Assistant. Home assistant reports the switch has the proper value set. And if I change it to 0 or 1, then it doesn’t work at all.

I’m having the same issue on the Gen 1 Add-on switch, but more inconsistent. So that won’t fix it.

I have noticed that the switches don’t seem to be setting parameters 22 and 23 correctly, and to get correct function, you may need to set the parameter OFF the desired setting, and then back ON the desired setting at BOTH the switch and the hub to get correct behavior.

That said, that method has solved issues at other install locations, but not this one yet. But may be worth a try.

Sorry, I’m confused. The manual does not show a parameter 23. Parameter 22 (Switch Type) is not “On” and “Off”, it has three states.

Well, @doublepedaldylan, even though I was confused, I tried what I thought you meant. I changed Parameter 21 to non-neutral, then back to neutral. Then I changed Parameter 22 back to load-only, and to 3-way momemtary again. That order of parameter setting seems to have fixed it! Thank you so much!

1 Like

Glad it worked! I’ll have to try it on my dimmer again, maybe I failed to follow my own advice there. Sorry about parameter numbers, I was going off memory. Must be 21 and 22.

FWIW, I only did the parameter changes at the hub. Thank you again!

Can confirm this worked for me as well!

Hi - can anyone provide the options and values for parameters 21 and 22? They aren’t in the documentation that came with the switch, so “non-neutral” and “load-only” don’t mean anything to me. Thanks!

Here is a link to the entire thing that @harjms just posted a snippet of. This should have been included with the switch but you can get it here:


Thanks for the info. The doc included with the switch ends with parameter 20 which is why I was confused.

Oddly, I had to set mine to non-neutral and 3-way momentary to make my GE Aux switches work. Setting to neutral and 3-way momentary did not work with my Inovelli Red or Black dimmers. I indeed have a neutral hooked up.