LZW31-SN - OpenZWave Pairing Problems

Been getting through my 10 switch install this weekend, have one that’s being problematic. During the ozw.add_node service process for this switch, something went wrong. I know this because in MQTT Explorer, it only had about half the topics as the other dimmers. In HA, I saw the device show up briefly under the OpenZWave integration, but it only had the 1 entity (switch) and not the typical other 2 power sensors. After I let this sit for a while, and doing a reboot of HA, I decided to attempt to unpair it and start over. It just gives my a red flash on the LED and won’t unpair. I know it’s connecting to the network, as the zwave signal test comes back green.

Now - in HA - the device (which used to say LZW31-SN) is called “unknown”. I can’t seem to unpair it…How can I do this? I thought about just deleting the entire node/topics/messages from MQTT Explorer, but I’m noobish with zwave/mqtt…


Solved. Needed to manually delete the entire node and topics from MQTT (using Explorer) and then factory reset the switch. After this, it paired properly. Home Assistant still has an orphaned device in the OZW integration…but for now my issue is resovled.

You can remove the orphaned ozw item by sending


with a payload of

  "node": 56

Is this MQTT or a HA service call?


I had some odd pairing issues with a standard pair. The switches would connect and query successfully but immediately be marked failed and then be subsequently removed… As soon as I tried the secure pair they’ve gone off without a hitch… not sure why.

Spoke too soon. My switches are having issues staying in sync or seeing big delays. Can’t add unsecure…

Running dimmers in secure mode does add a bunch of extra overhead. What’s the size of your Z-Wave network and what other devices are you using?

In the past I had major issues with the firmware version on Zooz Zen27 dimmers effectively bringing down my entire network because they were overly ‘chatty’ on state changes. I’d suggest closely watching the OZW logs while