LZW31 w/ Hubitat - Dimming Smart Lights

Hey All,

Recently purchased a Hubitat Elevation Hub so I could use all of the scene functions of my LZW31 Red Series Dimmer switches. I’ve figured out simple lighting rules but haven’t figured out dimming. I’m using smart recessed lights with the switch so I’ve disabled the internal relay. When I hold the switch button up/down, the led strip does not move like it does when internal relay is enabled. How do I create a rule to dim my smart lights while holding the switch button up/down? Can I make the led bar indicate brightness level as I dim? Also would like the led strip to turn off or change intensity when I press down x1 to turn my lights off. Thanks in advanced!


@Eric_Inovelli little help please…

Exactly same question here.

This works with hue lights and the CoCohue lighting app. It is easy to set up and works great. Hubitat doesn;t allow group dimming to avoid the popcorn effect.

The only way I was able to get it somehow working - is to turn on the dimmer, disable local relay and then use webcore to manually program up/down buttons to turn lights on/off. However now dim level is totally of from level indicator on the light and I haven’t found the way to dim the lights from the switch - instead set up smth like double tap will dim to 10% etc.

@Yoshi98bc - Could you explain group dimming? I have two bulbs included in Hubitat. I created a group that included those two bulbs. I can dim the group via Alexa or dashboard. Is there something different than what you’re describing?

So if using smartthings, it’s gonna be painful to get dimming with the dimmer switch by holding up or down on the dimmer. U can do it with smartthings plus hue B smart app since it supports group dimming.

In hubitat, group dimming means all lights dim at same time, not one followed by the other. Hubitat doesn’t support this. You can however do this with Cocohue app and inovelli dimmer with a modified driver. Works awesome. It will allow group dimming of hue lights only. So if have hue lights I would go for it.

What I did is disabling local&remote control and then using webcore to program 1xUp for turning Group on and 1xDown for turning Group off. So no dimming at all but at least lights are always powered.
What I’m going to try is to put “Load” wire into “Line” connector so lights will physically will be always powered. And then watch dimmer’s level and match it to the lights. Any objections why this won’t work?

Actually I find the reason not to do that - in case something will go wrong with the hub I won’t be able to turn dimmers back into dumb switches by just enabling back the local relay.

@Yoshi98bc when you refer to Hubitat and the “modified driver” is that for the Inovelli switch or for the Hue? I see that CoCoHue has a set of Hue drivers associated with it.

If I could get dimming at the switch for my Hue bulbs that would be awesome.

So I use the modified inovelli habitat driver for their dimmers. Its called the advanced driver. You can find it in the habitat forums and in these forums.

The CoCoHue app has to be installed as well then you pair the hue devices to habitat thru the CoCoHue App. Then you use Rule manger to set up Rules using button device to set up the dimming. Works awesome. Very little lag at all.

Hope this helps

Ok, one more problem with disabling relays is even despite I have “State After Power Restored” set to 100 (previous level) but after power failure my smart lights won’t have power. So I need to go manually to every dimmer, enable relay, turn on the lights (even if I don’t need them) and turn relay off. Repeat 16 times.

@2vanger I’ve experienced this as well. I’m not sure if the behavior is a flaw or intentional. I could see valid arguments for having them recover to the off state after an outage.

Following an outage, I’m able to turn the switches on via a command from the hub (Hubitat). I have local control disabled but have z-wave control enabled. It doesn’t solve the issue of the switches resuming from the outage in the off state but it may save you some work if your setup also supports this.

Another possibility would be to set up a rule that would turn the switch on any time it was off but I’ve not implemented anything like that since my power is generally stable.

I’ve disabled remote control because I originally thought that it will be a good idea to add dimmers into hubitat groups to control them all together. I may reconsider removing it from there and reenabling remote control just for that purpose.