LZW41 power outage setting

I bought my first LZW41 bulb and cannot seem to configure Power Fail State Restore option. Incan change it to turns bulb off and it reverts back to Remembers last state. Also, in this state if the power is lost when the bulb is off, after power comes back, the bulb turns on. Any help would be appreciated!

@bcopeland - I know you’re the resident Hubitat and Ilumin master here and have been making some awesome changes to the drivers. Have you seen this before or are you able to point him in the right direction with Hubitat?

We’re basically having an issue where the bulb doesn’t come back to the last setting after a power outage.

@JBGS- just to confirm, do you have this driver installed?

LZW41 Device Driver Raw Code

Hang in there, we’ll figure this out!

1 Like

I’ll check with mine real quick…

Ok… I can confirm with the latest driver it is holding the load state as it should…

I think there was a bug with one of the older driver versions that wasn’t holding that config correctly

If you download a fresh copy of the driver it should work fine…

1 Like

I have updated the driver code provided and still the same issue. I make a selection, save preferences and when I come back to the device once more it reverts back. Should I delete the device or perhaps some sort of a reset?

Ok… The driver sets the configuration variable and then reads it back and sets the preference based on what it reads… I do this for confirmation that the device has stored the config variable… I tried this with mine and it did work for me… But can you enable debug log and save the preference and then post the log?

I always like my preferences that are device config variables to match what the device has stored…

2020-04-12 09:31:12.777 am debug parse:zw device: 0E, command: 7006, payload: 02 01 00 , isMulticast: false

2020-04-12 09:31:12.195 am warn debug logging is: true

  • colorReceived : {red=null, green=null, blue=null, warmWhite=255, coldWhite=0}
  • initialized : true
  • firmware : 2.26
  • powerStateMem : 0

Hey @JBGS - can you try removing the device and then include/pair it again?

OK. I will give it a try. Thanks!

That debug log didn’t show it setting the config…

I have excluded and included the bulb. It was found as “device” despite the fact that I have the driver installed. Once I updated the device, same issue with setting reverting.

Ok… What were you trying to set it to?

bulb turns off option

Ok so this portion is what the bulb sends back after the config is set and I set mine to the off state like you wanted:

parse:zw device: 35, command: 7006, payload: 02 01 02 , isMulticast: false

Command: 70 06
Zwave command class: configuration - command : configuration report

Payload: 02 01 02
Parameter number: 2
Size: 1
Value: 2 (which is off)

Yours sent back remember last state value 0

Try that again for me and post the log again

All I get in the log is this now:
/device/edit/198)parse:zw device: 0E, command: 5A01, payload: , isMulticast: false

crap… that is device reset locally… It is a message the device sends when it unpairs itself from your z-wave network…

It sends that when you factory reset a device

after that message… your bulb is no longer on your network and will have to be re-paired…