LZW42 Slow ramp time

I’m using the LZW42 bulbs with the inovelli fan switch. Any way to adjust the ramp on/off time to be faster or instant? Love these bulbs but that could be a deal breaker for me.

How are you controlling the bulbs? Via a wired connection to the dimmer , a scene or Zwave association?

I’m using the bulb in a lamp and controlling it via zwave association from the fan switch.

Speaking generally regarding Inovelli dimmers, there are several settings that can impact the perceived ramp and dimming. In addition to the ramp rate, there is the dimming speed. There are separate settings for at the switch and via the hub. Additionally, you can tweak or disable the physical on/off delay, depending on whether or not you are using scene control.

I believe @jtronicus has the fan/light switch controlling via association and may be able to comment further.

Maybe I used the wrong terms. I’m not so much looking to change dimming speed. I just want the light to turn on instantly and off instantly when I trigger and on/off state with the fan switch. I already tweaked my fan switch settings to do this for the actual fan light and it works great. Doesn’t seem like there are a lot of options for the bulbs though.

For this switch it is the the dimming speed and ramp rate that factor in. I’d set all four (P’s 1 - 4) to 0.

P51 to 0 to remove the delay, unless you’re using scenes. FW 1.36.

Also not sure how association factors in here.


To my knowledge, there isnt a way to do this with zwave associations (it can be done using scenes though). I believe it is a limitation of the current firmware.

When using the switch to control associated bulbs, the switch always instructs the bulb to use its (the bulb’s) default dimming speed, regardless of the parameters set on the switch. Since the hard-coded default dimming speed of the bulb is 3 seconds, this means there is no easy way to get it to instantly turn on. I believe this could be fixed in the switch firmware (by sending a dimming duration based on parameters 1/3) or in the bulb firmware (by adding a config option to adjust the default dimming rate).

For my own switch, I just ended up using scenes to control the lights. Hopefully at some point in the future this will get fixed as it also affects the regular zwave dimmers.

I’d agree with above. The dimmer doesn’t send the ramp rate info to associated devices, so the ramp rate is the 3 seconds the bulb defaults to.

Decent hubs can send a ramp rate along with a level value.

Does this rely on the hub? I haven’t gotten into using scenes much yet. Ideally I would like to control it directly to reduce the latency time. I have another lamp that is capable of using a wall plug dimmer addon and it works great using associations. I need to go the route of a bulb on my bedside lamp because it has built in USB ports that cant be bothered by a pluggable dimmer.

It does rely on your hub, so there will be some latency depending on your hub. I use Home Assistant, so everything is local and the latency is barely noticeable, especially if you enable parameter 51.

Nice! I have param 51 already enabled and also use home assistant. I will give it a shot. Thanks!