Might be missing a preference setting with LZW31-SN - Strange behavior happening

So I installed 2 of these dimmers in my home and have programmed them according to what I found on the main site. Everything works as expected except it looks like it’s doing some additional dimming before it goes to what I’ve programmed. Here’s an example of what I have programmed:

So on the “button 1 held” what it’s doing is it’s dimming down to almost off before it goes up to the correct level for some reason. For example, if the lights are currently at 50% and I press the paddle down, it’s supposed to go to 40%. It’s actually dimming down to about 5%, then goes back up to 40%. On the up press, it doesn’t fade, but it’s taking about 2-3 seconds to react. Did I miss something in the preferences or somewhere else?

Is this with smart bulbs? Did you disable internal relay? Otherwise I think it would be getting two commands: 1 to turn off the device and 2 to reduce lights.

Not really sure where I would disable that. I did not see a preferences setting for internal relay. Thank you!

Are you using smart bulbs?

If so you want to disable the internal relay by hitting the config button 8x (More details are in the instructions, e.g. led blink acknowledgement)

If they are just normal LEDs attached to the load I am not sure what you are trying to do is possible, since the tap 1x on up or down will trigger the normal turn off and turn on.
Maybe you can achieve this by turning on the ‘Disable Local Control’ option. I am not sure if the device will still send scene control functions when that is enabled.

Thank you @timrudd12. Not sure what I did to fix it, but it’s now working correctly. I think I had an old rule in there that I managed to delete. The bulbs I’m using for this particular switch are 4 Kitchen LED dimmable bulbs, but not smart bulbs.