No scenes on LWZ30-SN, no logs for extra button presses either

I’m sure I’ve got a facepalm, but I haven’t been able to find it.

Inovelli LZW30-SN, using latest firmware (just updated this morning, 1.19).

Driver is latest 2020-08-07.

  • Inovelli Switch Red Series
  • Author: Eric Maycock (erocm123)
  • Date: 2020-08-07

Driver in “Devices” is set correctly to the new driver

I have a working scene that I made this morning, following the instructions in the main hubitat docs,
That was easy. I can use the scene activator inside hubitat just fine to turn that scene on and off.

So, I tried to connect that somehow to a double-tap of a particular switch.

I tried both Rule Machine following a post in tips and tricks in here, end also using Simple automation rules (Maybe I followed a set of instructions for the simple automation rules, but maybe I just winged this one, can’t remember exactly).

Anyway. I had problems, couldn’t get a thing to work. As a troubleshooting step, I opened and watched the logs to confirm what was being passed when I double-tapped so I could confirm my rule was using the right button.

And guess what? I get no logs whatsoever for any double-tap, tap and hold or anything but just the regular up/down.

So I’m missing something simple, I’m sure.

Some other things I have already noticed/fixed/tried:
Found I DID have an older driver (from March or so of this year), so I updated that this morning. No change to anything. Well, newer driver, but you know what I mean. :slight_smile:

Still had the old “child device” driver, so I removed that since it’s no longer needed. No change. I think I restarted the whole hub here after that too. Just in case.

I’ve turned the “Disable on/off delay” option from driver 1.19 off and on a few times at various times, this works perfectly (proving I have new driver, and new firmware). It is currently set to Not Disabled and when I press a button, there’s the half second delay before anything happens so it’s waiting for a second tap or whatever. When I have this set the other way (Yes, Disabled) then the button presses happen immediately. But anyway, it’s set the right way to use scenes right now:

I have also confirmed I get the same behavior (no logs for anything but single-taps) on several other switches - both 1.19 firmware and also 1.11 firmware. Indeed, every single switch in my system I’ve tried, I never get any additional logs.

So, what really simple thing did I miss?

I know it’ll be a facepalm.

@mahlerrd - It may be because you’re using a Black Series switch instead of a Red Series. When I include a Red Series, it shows up as Inovelli Z-Wave Smart Scene Switch S2. Your’s only shows up as a Smart Switch. I think you need to look at the device to ensure it’s a Red Series. If it’s a Black Series, you need to select the correct driver.

To add to the above, assuming you are indeed using a Red Series model: what Hubitat hub firmware are you on? I’ve seen some 2.2.3 users mention similar problems with scene events getting through, though I can’t remember if with debug logging (or both debug and info/description) if you would at least see something in the logs. In any case, that is probably something that will be worked out in a future Hubitat hotfix. In the meantime, I’m not sure what you can do (could try 2.2.2, which I can’t remember if was affected by this problem, or 2.2.1 if you have it).


I was just wondering that same thing, and I looked back. One order was all red series, one order was all black series. And I wasn’t paying attention to which I put where (which happens when you are building a new house, have 70 of the silly things to install, and forgot you mixed red with black. Duh.).

So yeah, my poor luck I stuck a black where I wanted a red. I’ll have to do some swaps.

One puzzling piece though - Why did that switch have the delay when pressed before I updated to 1.19 and set the no delay? Were the black, non-scene enabled switches also having that same delay? Why? Inquiring minds! :slight_smile:

Anyhow, yep, main mystery solved.

Great question…it may be more driver related with firmware acting…or it was the placebo effect.

Either way, glad it’s been resolved.

Yes, the original firmware for the Black switches and dimmers still had a Red-esque “delay,” even though in the case of the Black models there was nothing to wait for (no multi-taps). In the latest versions of both Red and Black firmware, there is an option (parameter 51 in any I recall) to disable this. In my experience, the switch seems to think it’s set to disable the delay after upgrading, even if you never set the parameter, so I’ve always had to go and configure it as desired.

Why you wouldn’t want it this way all the time on a Black Series, I don’t know… :slight_smile: