NZW30/30s challenges

Just swung my devices over from Smartthings to my new C7 Hubitat. Went pretty smooth until I got stuck on my NZW30/30s v1.

First, not exactly sure which version (30/30s) since I’m trying to avoid taking them off the wall to look if possible… I performed the device code update in habitat, and aligned those devices to that Type. I can see physical activity (push on/off) I make in the device activity, but none of the buttons on the app are showing any activity.

Thinking I may have excluded from ST wrong, I went through that sequence and confirmed exclusion again. And then ‘included’ into Hubitat again. Same no app//website activity seen.

Any thoughts?

Hey @EricM_Inovelli do you have any gen 1’s laying around you can test this on? I feel like I saw this posted in the Hubitat Community too, but I could’ve just been dreaming.

If not, I think there are some around the office here, I can try to emulate.

1 Like

New to hubitat, but happy to send any events/logs you may need.

I believe there is a problem with the latest firmware on the C7 when using custom drivers. If you switch over to a custom driver a lot of the device features stop working. I am waiting to hear back about this problem.

When inclusion is run, it identifies the switch as ‘keyWe Z-Wave Lock’.

Since i’m such a patient guy :wink:, I tried again tonight. Something someone mentioned over at hubitat, i tried exclusion and re-inclusion with all authenticaion check boxes empty. Worked for one and not the other so far.

1 Like

Before i remove these, any firmware updates i can try out with a flash through the Hubitat updater? Still are behaving a bit buggy. These were purchased in Jan 2018 off of Amazon.

Data * deviceType: 7680

  • inClusters: 0x5E,0x86,0x72,0x5A,0x85,0x59,0x73,0x25,0x27,0x70,0x5B,0x8E,0x55,0x98,0x9F,0x6C,0x7A
  • zwNodeInfo: D3 9C 00 04 10 01 5E 86 72 5A 85 5C 59 73 25 27 70 5B 8E 55 98 9F 6C 7A 68 23
  • protocolVersion: 4.61
  • hardwareVersion: 1
  • firmwareVersion: 1.01
  • deviceId: 7680
  • manufacturer: 349

Yeah, I can PM you the link to those old firmware files. Can you let me know what the date code is on the switches?

It should say it on the front of the metal plate if you unscrew the faceplate – it will be a four digit code: 0418, 0818, etc. Or if there isn’t one there, let me know.