NZW30 On/Off works at switch but not in app, and other weirdness

I’ve had an NZW30 w/ Scene Control sitting around unused for a while and finally got around to installing it. It paired to Smartthings just fine, and I assigned it the correct device handler (same as another one elsewhere in the house). It’s controlling an outlet with a lamp plugged into it.

Here’s the weirdness:

It turns on and off just fine at the switch.
It does not turn on or off via the app. (Just sits on “Turning on”.)

Scenes work just fine via the app. (Like a simulated double tap to turn on a different light.)
Scenes do not work when I physically double tap the switch.


Did you figure out how to resolve this issue?

I’m having the same trouble. My switch has been working for at least a year. I recently found the same as you, I can turn this switch on/off from the physical switch without issue but if I try to trigger the switch via SmartThings it just shows “Turning On” but never does.

I’ve tried running a Z-Wave repair. This appeared to run as intended but there has been not change in this switch behavior. Still won’t work via the app.

I’m wondering if I should exclude the switch in my SmartThings app and re-include it. Sort of trying to start over or “reset” if you will.

Curious if you solved the issue and if so what did you do?

Hey so I just had someone write in with this issue to FB and removing and re-pairing fixed it.

So random that this is happening to this specific model today.

Appreciate the feedback. Removing then re-pairing the switch solved this issue for me. Thanks!