Power Reporting of Inovelli switches

I’m on Hubitat and changing the “Active Power Report” and “Energy Reports” for both the on/off and dimmer switches don’t seem to do much. Because the power on some of my switches keep fluctuating every few microseconds (which is another issue), I get a ton of reports sent to the hub which ends up slowing down my hub.

As an example, one of my switches fluctuates between 1.9W and 2.1W. I set my “Active Power Report” to 40% so I don’t expect to receive reports for changes between the 2 power levels. However, I still get each of those changes every few microseconds.

Please help look into this. Thanks

What do you have the Periodic Power & Energy Reports parameter set to? If you set it to 0 thinking it will disable it, I found that it instead sets it to 0 minutes, which means it constantly sends reports.

1 Like

Left that at default i.e. 1 hour.

There are definitely reports of “0” for many of these parameters, which is supposed to disable the feature (something I’d prefer for all switches where I don’t need power monitoring…which is all of them, really–no need to bog down my Z-Wave network with these messages), not working due to a bug in the current firmware. Like the above, I notice it happening very frequently when I change it to this — the exact opposite of what I want.

That being said, you’re still at settings that should work, so I’m not sure what’s going on. Perhaps you could try changing them to another value and then changing back? (I haven’t heard of it being necessary with this parameter, but there was at least one where some people noticed this help it get set correctly.) You might also try just increasing both thresholds regardless in case the specified ones don’t match the real-world changes that need to happen for these requirements to be met — there could just be another firmware oddity.

Thanks. Done this multiple times up no effect unfortunately.

Have increased to 50% and there are times when it seems like it works (less reporting), then it stops. Clearly buggy firmware

Along those same lines I don’t need power reporting, so with my Hubitat C7 using firmware, I set parameter 18. Active Power Reports, to zero for all my red dimmers, LZW31-SNs. Having done that do I need to set 19, Periodic Power & Energy Reports, and/or 20, Power Reports, at all?

Someone on the Hubitat site suggested these settings:
18-set to 0
19-set to 32767
20-set to 100

But if I don’t need to set 19 and 20 I just as soon not take the time to do so.