Problems pairing Red Series Dimmer Switch - Gen 1 SmartThings Hub

I hope someone can help with the following, it has got me completely stumped. I am having a problem pairing new red series dimmer switched to my SmartThings hub V1

I already have a number per of the red series inovelli switches and dimmers connected to the hub and they all work great.

I have tried to connect 2 brand new dimmers and have had the same problem with both of them.

The switch shows excellent connection with the range check, nonetheless I moved the hub to be 6 ft from the switch.

I set the app to pair with a new device (and I tried the classic smart things and the new SmartThings app) and then put the switch into pairing mode. The light pulses as you would expect and then shows the green light. The app does not acknowledge the switch has been paired.

I have tried …
excluding the device - the exclusion process works every time
I have closed the app and reset the iPhone
I have rebooted the hub
two different brand new switches.

I am hoping someone can help with some good/new ideas …


A couple things to try:

  • You stated that you excluded the switch. Inovelli suggests starting the include then 3x on config. That’s one way. The other is to do a general exclusion via the hub. (Zwave exclude under Zwave utilities in the IDE).

  • Exclude then factory reset the switch

  • When you include with the new app, are you adding by scanning the barcode?

1 Like

I have tried adding the switch by using the barcode and ‘scanning locally’.

I tried (and then retried having read your message) the methods you described

unfortunately still not able to pair the switch.

Sorry that didn’t work. Have you been successful in pairing other switches before, or is this the first?

I don’t have any experience with a Gen 1 hub. Hopefully someone that is using a Gen 1 hub can provide some insight.

I have previously paired
GE switches and dimmers, inovelli red series switches and dimmers

When you put the device into pairing mode. (pressing button 3 times).
The LED slowly pulses blue.
After a short period the LED goes green

i understood the green light means it is successfully paired, the app is not showing the device is paired.

What triggers the switch to show the green light that makes it think the pairing is completed ?

Did you look in the IDE?