Red Dimmers Fall Asleep?

I just installed a red series dimmer and it feels like the switch falls asleep after a while. When it is ‘asleep’ it doesn’t turn on with a single top on top, and the LED light is a faint blue towards the lower half of the bar.
But when I hold down the top, the light suddenly fades on. Then when I press the off and on buttons, they work as expected. After some time it resumes the ‘asleep’ stage and won’t turn on with 1-tap.
Here’s a video of the situation:

Has any one seen this before? I’ve even tried a factory reset (control button fort 20 seconds), with no luck.

It sounds as if when you think it’s asleep, it’s actually on, but at a dim level so low that the bulb(s) aren’t illuminated. So when you do a single tap up, nothing will seem to happen because the dimmer is already on. When you hold up, then the dimmer ramps up the brightness. You think it’s turning on, but in fact it’s already on and the brightness is just increasing.

This is likely because you have set your minimum brightness too low, at a level below where the bulbs illuminate. To properly set this, change your min and max to 1 and 99. Turn the dimmer on and slowly decrease the brightness until the bulb(s) go out. Then set your minimum a few % above that value.

That minimum will become your new 1%. Now when the dimmer is on, it will be obvious because the bulb(s) will be lit. You won’t be trying to turn it on with a single tap up when it’s already on, as it will be obvious now.

You’ll notice that in your video, the tap up worked properly after you did a long press up to ramp up the brightness.

Another thing to remember is you can’t long press down to turn off. Short press down only. A long press down will just dim to the minimum level, but the dimmer is still on.