Red Series Dimmer Switch LZW31-SN: Notifications missing

Getting some weird behaviors from notifications. So I run a process each night to turn on notifications and then turn them off in the morning. Been working great and then all of a sudden - the notifications just are missing in the scene and in the app. Any way to turn off the notifications on the switch setting? I don’t want to have to reset the switch(s) as they seem to be working fine. Notification are still showing up on the switch settings.


1 Like

Unless you started with an older DH, your notifications should be child devices. Looks like that in your screenshot. Maybe I’m misunderstanding, but to turn of the notification, find the child notification device and turn it off.

There is no way to turn the notification off in the settings AFAIK. However, I’ve never tried removing a notification to see what effect that has.

The child notification disappeared in the app, but I’ll try it to kill it in the backend of SmartThings.

I saw that it disappeared from the scene but I guess it’s missing from Devices, too? You may need to exclude and re-add the switch to get it back.

Having this same issue, the child devices disappeared from my device list. Any solution to this yet? Lost all notification child devices for 3 switches. Running 1.48 firmware for probably 2 months with no previous issues. And I just looked at the IDE and they are all listed there, but not in my app. Just updated the device handler and still have the same issue.

1 Like

OK- I found a way to get them back without deleting the switch and starting all over. In the switch settings, I turned the create “disable local/remote control” child devices to true. It did something as when I turned them off, my notifications had reappeared in the app. I had to add the notifications back into my scenes, but it was better than starting from scratch. Hope that works for you too.

1 Like

I just tried that and it did not work for me. The switch I was working on was only using two notifications so I tried setting up a 3rd one, that worked. So I went back to notification 1 and 2, and deleted all the settings, backed out, then went back in and set them up again, that appears to be working for me. Aggravating though, hopefully they don’t disappear again.

OK, looks like I can delete or “unset” one parameter such as color and then go back in and set the color again and it brings the notification back. Also have to add them back to my scenes and automations, but at least I found a shortcut.

1 Like

I have three locations with switches at each using smartthings ver 2 hub.

ALL of my notifications just disappeared one day and have not been able to get them back. I have been through several iterations of excluding re-adding switches, updated and re-published DH’s and restarted the hub.

I also just tried the Child device disable local remote control

No joy.

Any ideas?