Red Series Dimmer - Unable to Enter Configuration Mode


My setup: GE Add-On with Red Series Dimming in 3-way config with neutral.

With the initial default setup, everything worked as expected – turned power on, blue indicator light on/dim, dimmer worked at smart switch turning lights on no problem.

I’m now trying to configure the switch for a 3-way set up – I held config button 10 sec, got green light then it immediately switched to yellow. Tapped config button 13 times but didn’t get the 1x + 3x blink (don’t recall what I got). I tried this a couple more time but still no 1x + 3x blink.

I then tried pulling the air gap but now I cannot get the yellow light after holding config button for 10 sec. I’ve turned the breaker off for a few minutes but still no luck. I also tried holding it for 20+ seconds but still, no response (LED bar stays blue/dim).

Hey @Dave – sorry for the issue here, this is definitely a new one!

Is there a way you can upload a video?

One other thing you can do if you are using SmartThings is configure this via the device handler rather than messing around at the switch.

Hi Eric,

I have not set up SmartThings yet, I was hoping to put this off a little as I have several renos underway. I have the same setup elsewhere in my home (red series + add on) and it works fine.

Hope the attached video helps.

Thanks for looking into this for me.


Hi Dave,

It’s clear the dimmer isn’t going into the config mode, but I’m curious about something in your wiring.

What is that loose black conductor at the Inovelli box? It appears to me to run parallel to the white which you’re using as your neutral. I can’t see into that box, but is that a constant hot too? It looks like you’re using a hot that is coming out of that mess of blacks from the top of the box. Not saying you are wired incorrectly, but it raised a question in my mind. Are you using a hot and a neutral from the same circuit?

Hi Bry,

Thanks for your reply.

The loose black wire was also connected to the same terminal as the feed/line wire, not a hot wire, it feeds another switch. I removed it to keep things a little clearer when taking the video but it obviously had the opposite effect. And yes, hot & neutral are from the same circuit. Just curious though, I’m very comfortable working with & understanding electrical circuits but I’m fairly new to the smart switch scene – would connecting the neutral to a different circuit have an impact.


There are a couple considerations. “Borrowing” a neutral, as it’s known, violates the NEC. This is prohibited so that you don’t return hots from two circuits over one neutral, potentially overloading the conductor. This pertains to anything, not just smart switches.

That mismatch will also cause issues if one or both or the circuits is protected by an arc-fault breaker.

Hi Bry,

Thanks for that information, Bry. I guess I was just trying to understand a little more about the internal workings of the ss ( smart switch). I didn’t expect it was checking the return path in any way, unlike the AFCI as you pointed out, or a GFCI for that matter. Yes, Borrowed neutrals or Shared, as we tend to call them up here in Canada, can be a issue. We use them quite often in commercial/industrial settings but particular care needs to be taken to balance and/or upsize the neutral. More often than not these days we’re asked to just run separate neutrals, that is until they see the pipe was under-sized. Anyhow, I digress, thanks again for the info. Not sure what my next step is.

Maybe there’s an issue with the Add-On switch and I should just remove that. Unfortunately, I don’t have a manual 3-way at the moment. Does the ss expect to see the Add-On or will it work without it? Is there any other way to test that the ss is functioning?


Hi Dave,

Eric should be along sooner or later since he asked you for the video.

In the meantime, you can try removing the Aux switch. I’m not thinking that’s it, but it’s so easy to do it’s worth a shot.

Try it as a two-way. Don’t swap out the Aux for a dumb switch. You already have the load patched up to the light, so just pull the neutral off the Aux and the red traveler off the Inovelli. By default, dimmers ship in a 2-way configuration, so it should work as a 2-way without tweaking any settings.

The thing that’s troubling to me, however, is that in your video you held the config button long enough that the switch should have factory reset, but it didn’t budge. I doubt removing the Aux will change that, but it’s worth trying.

Hmmmm… I’ve never seen that before where it doesn’t enter config mode.

I think honestly, it’s a bad switch. Can you shoot me a PM with your info and I’ll send a new one?

Hi Eric,

I thought I should share this with you first. The spoiler… I was able to enter config but still having some issues.

The following was done in the order listed.

  1. First I tried Bry’s suggestion of removing the Aux switch but this had no effect.
  2. I then pulled and reset the air gap, since that’s when I originally started having problems.
  3. At random I was tapping on the paddle and config button and noticed I got a response every time I pressed the config button 3 times. It would begin flashing the notification bar in red. I didn’t keep track of how many times.
  4. I was now able to enter config and set the switch for 3-way switching.

The problem now is that I cannot turn the light on from the Aux switch. I can dim from the Aux but when I press the up paddle it turns off and won’t turn back on.

I’ve attached 2 videos. One turning light off from aux but won’t turn on. The other, dimming from Aux but turns off from dim state when up paddle is pressed.

Full On - Full Off

Full On - Dim - Off

The Aux behavior could just be because the switch hasn’t been programmed. But as you’ve noted, it won’t go into the config mode, so that dimmer is still wonky. 3x on the config should get it to pulse blue, not red. Eric probably knows what that means.

Interesting that it started responding again. I wonder if it will factory reset now. (30 second hold on config)

Yeah this is really strange. I’ve honestly never seen this behavior! You have a ghost :slight_smile:

Yeah @Dave – I’d try @Bry’s suggestion to factory reset it if possible. Hold down the config for 20 seconds until the bar turns RED.

Then when you try pairing it to your hub, it should pulse blue. If it doesn’t, then let’s get this one swapped out for you.

Hi Eric,

I was able to factory reset as well as setting the switch for 3-way communication (pressing config button 13x, etc.) But again, same behaviour as before (i.e. Aux switch can turn off or dim dim but cannot turn back on). I will PM you with my info.

Thank You,

Hey Dave,

Can you share the IDE info where it shows your parameters?

I’d like to confirm it’s sticking correctly from within ST.

Hi Eric,

As I mentioned in one of my earlier posts I have not set up the ST yet. This is something that I’ve been wanting to do but with several renos underway I’ve just not had the time.

I now have 9 of your switches running with 2 of them successfully set up as 3-ways – soon to be three 3-ways once this issue is resolved. Yeah, I know, I really do need to get these automated.

Ah sorry, I must have missed that. Is there any way to setup ST to confirm? I’m only asking bc I’ve seen this issue where sometimes the parameters don’t, “stick” when you set it from the switch.

If it’s too much of a hassle, we can have Aartech swap it out for you. I just wouldn’t want you to run into a similar scenario.

Are your other switches paired to an aux switch?

Hi Eric,

Finally got around to setting up the switch on ST. I’ve attached the IDE info.

And, yes, I have two other switches, both lzw31-sn, that are attached to the same type of Aux switches and they have been working fine for several weeks.

Dang, looks like ST changed some things. I don’t recognize that device type. Let me add Eric M. for reference, but could you do the following for me?

Install this device handler:

Then once it’s installed:

  • Open up your ST App and click on your Inovelli device
  • Click on the three dots at the top right and select, “Settings”
  • Scroll down to where it says, “AC Power Type” and select, “Neutral”
  • Then scroll down to, “Switch Type” and select, “Momentary Switch”

And then take a screenshot for me?

EDIT: Whoops, thought this was a PM. @EricM_Inovelli – do you recognize this IDE switch type? Maybe ST now is recognizing our switches, but giving a limited parameter view?

That’s a red dimmer.

One of mine:


Hi Eric,

Went through the process of installing the device handler and for the most part, everything seemed ok. However, I never did see a device called, “Inovelli Dimmer Red Series LZW31-SN” In the “Type” dropdown, I only see, “Inovelli Dimmer”. I also don’t see “AC Power Type” for this device in ST App.

I’ve attached three screenshots that make up all of the parameters from the app.