Red series switch won't include

Switch works fine by itself. Test the signal strength and it shows green. Won’t pair with my Hubitat. I tried master reset. I tried exclude then include. I have a repeater less than 4 feet from the switch. It works fine connecting to the hub. But this switch, which I only bought one to try out won’t get included. It always flashes red at the end. The switch does show the blue flashing lights for 20-30 seconds. Then just flashes red and goes off. If the signal is strong why won’t it pair? How do I know it isn’t broken?

Hey @dajum - welcome to the forums, glad to have you!

Let’s figure this out. If you don’t mind, I have a couple of questions for you.

When you ran the exclusion, did the light pulse blue and turn red or did it turn green? I know you mentioned for the inclusion, it turned red, but did it for the exclusion as well?

What type of repeater are you using?

The exclusion never got any response. Not from the 3 pushes or after that either.
Aeotec extender6 for the repeater.

Alright, one last thing to try is to reboot your Hub and then try the exclusion again.

If that doesn’t work, then we’ll swap it out for you with one we’ve personally tested.

Sorry for the headache!

Rebooted the hub. Checked that all the other devices were connected again, including the aeotec repeater. Tried exclude again. No response from the switch. Should there be some signal? Note that the instructions don’t say if the load should be on or off when doing the pairing. As a newbie here I don’t really know so I tried both ways.

But before I declare it is bad (unless you are pretty sure), I think I should try it in a position close to the hub. Right now it is on the lower level and the hub is one floor up. But 40’ away with a few walls between them. Of course the repeater is a little farther than the switch and the same walls, and I know it works. And of course the switch itself says it gets a signal. So do you still think it is a bad switch?

Yeah it’s definitely hard to say, unfortunately. It’s interesting that it’s showing the signal, but not pairing and you mentioned the light pulses and turns Red, which indicates failure, which is strange because all else seems to work.

I don’t know much about Hubitat, but we’re you able to find the directions here?

https://inovelli.com/shop/smart-light-switches/zwave-smart-switches-gen2/z-wave-on-off-switch-neutral-required-scenes-notifications/#installation-instructions

(Scroll down to the Hubitat section)

I’m not sure if you need to add the driver first or not, but maybe that would help.

Last ditch effort would be to move it closer, I agree.

Keep me posted - either way we’ll get you up and running!

I always add drivers before devices on my Hubitat.
Check that you are not using secure include.

I did add the driver first and did follow the instructions in the link above.
The hubitat documentation shows that only locks and garage door controller use a secure join. Don’t see anything on the interface to make sure it isn’t secure. @icepick how would I make sure it isn’t secure include?

On hubittat z-wave details make sure it still says Secure Join Locks/Garage Doors

I’ve wanted to use this feature but haven’t since I figured it would see my ST hub as well as my Hubitat hub so I wouldn’t know which it thought was strong enough to join any way. I only have my ST hub up still for my Neato Botvacs since I haven’t found an app for controlling them on Hubitat yet. But I would think having multiple hubs with Z-Wave radios would be confusing.

As far as pairing on Hubitat the drivers don’t matter until the device joins but having them installed first in this case (Since we know they will be needed to access the full feature set) would be more convenient although it still detected mine as devices and I had to then choose the right driver after joining then press the Save Button and Configure after it reloaded. One of my 4 switches had to be un joined before it would join not sure why.

I agree with @IcePick to make sure the Z-Wave setting is for secure join for locks and garage doors only.

Thanks to all for the help!
It was in locks and garage door only mode. So I moved my hub down next to the switch. Paired in seconds. Moved the hub back up stairs and also moved the repeater back upstairs. Switch still works fine. I gotta say that pairing devices is a real pain. Hasn’t worked very well on any zwave devices unless the hub is inches away. Even powered devices which just seems strange. Is it the hub or the devices?
Dave

@dajum - I didn’t notice an issue with pairing any of these new switches, nor did I notice an issue after moving my already z wave connected device from ST to Hubitat. I wonder if it’s a hub issue. Do you have any other devices to pair?

My guess is you don’t have enough Z-Wave repeaters in your mesh yet I have been able to pair my switches anywhere I have installed them so far. Usually the only devices that need to be that close to the hub to pair are the secure devices like locks and garage door controllers, because during the pairing cycle they limit their broadcasting power to prevent eavesdropping during the join.

@Terk you could be right. I only have 5 z-wave devices, 2 being repeaters. All the other devices are not zwave. I’m starting slow to see how it works. Everything works fine after pairing. I expected like you to be able to pair the switch without moving the hub, especially with the repeater right by it. Don’t understand why that doesn’t work, and haven’t found an explanation for it anywhere. Appreciate all of the advice I’ve gotten so far.
Dave

and you know the repeater is working and part of your mesh?

@IcePick yes they do seem to be working, but I’m not sure exactly how to tell. I’ve seen people post maps of their networks, wondering how to generate those? Is there a good tool to use to do that? link?

If you have the Hubitat with external stick I think you can plug it into your PC and use something like Z-wave PC controller software.

Otherwise get a USB stick like Zooz sells or the Aotec z-stick. The Z-stick is a really handy tool for excluding devices, I used it when I moved everything from ST to Hubitat.

HomeSeer has a product that looks cool - I have no experience with it.
HomeSeer Z-Seer+ Z-Wave Diagnostics Software

Conversation over at hubitat community about Aeotec repeaters falling off the mesh.