RGBW Bulb (Project Genesis)

Ok…this is bad. I just placed an order for another 11 of the iLumin Bulbs…that brings me to 43 in total. The crazy part is I just ordered 3 new (old) Fan Light Kits so I can put these in my ceiling fans. Funny how everything is small bulb form factor and LED now. Thank goodness for eBay. I found kits from a few years ago that people still have online so I can put A19 bulbs in there! With the number of bulbs I have purchased, I am hoping for few things: 1) These bulbs last a long time. 2) I have put a dent in your Holiday Pack and Unboxed inventory of switches and lights. 3) Everyone is safe and healthy in these uncertain times. Thanks for helping me achieve my RGBWW dreams.



Is there any chance that we’ll see last-state restore coming to the bulbs currently being sold? I bought 5 of them just to play with. No complaints initially. Controlling them from a switch via association groups. All was fine until the power decided to briefly go out at 3am one morning and when it came back I was awaken by all the bulbs turning on.

hi, did you install the device handler? that’s what makes it possible to set it to remember their last state.

Thanks. I must’ve somehow installed an old version of it, as it was missing that config. I followed instructions somewhere on this site, so they must’ve pointed to an out-of-date device handler or something. Anyways, I managed to track down the new one, and it appears to be working now.

great!! same happened to me when I got my first bulbs and Eric helped out with that! glad you could sort it out! :muscle::muscle::muscle:

Hey sorry about the confusion guys – can you point me to the spot on the site that has the old driver? I’d like to get it fixed so that it doesn’t happen in the future :slight_smile:

Hmm, I honestly couldn’t tell you where I found the out-of-date handler, as I’m not able to find the link to it now. Perhaps it has already been fixed, or maybe when I originally installed it, I did it via a Google search or something – regardless, I’m not able to find it now.

No worries, thanks for following up!

A request for the next bulb firmware- can we get adjustable ramp time? Right now the ramp time is really slow…

1 Like

i placed an order for 20 more bringing my total to about 37 lol , i Too am hoping for better stability and some effects in the future … i got the basics of rule machine down but for ( complex effects) I still need more practice :laughing:

1 Like

I Have about 7 modern ceiling fans at home that come with a led light which is flat like a pancake i have removed the led piece and modified it to be able to use regular bulbs lol

1 Like

Just thought of another feature- disable repeater. If the smart bulb will be in a switched socket, IE if it’s on the same circuit as some dumb bulbs, then acting as a repeater is undesirable because the network will try to route through it and then it will disappear leaving broken routes.

So there should be a config option for like ‘switched bulb mode’- when enabled it reports itself as a non-repeating node (like a battery powered device). That will I think need an exclude/include to take effect…

(And I’d still love to get adjustable ramp time on the current RGBW bulb- lack of that is what prevents me from buying more right now…)

Since this thread got revived, it reminded me of a feature I was thinking about: controllable security while pairing. The bulb only supports S0, which is less efficient and less secure than S2 (and still less efficient/more chatty than non-secure pairing regardless), and while some hubs/controllers allow you to choose whether to pair securely (and the bulb will agree), it looks like new 700-series S2 controllers won’t allow you do that. Hubitat is the first I know of to market, but they’re saying it’s all the kit lets you do, so it will likely affect all certified Z-Wave implementations at some point.

How lots of other devices handle this: separate ways to get to inclusion mode for secure vs. non-secure pairing (on lots of sensors or switches, it may be holding a button instead of pressing it, or pressing it so many times instead of so many [other] times; I realize this is a bit more challenging for a light bulb, but maybe so many power cycles for secure vs. non-secure?). Or just use S2 (which I’d gladly use over S0 and would consider using even if non-secure pairing were also available), but I assume that would require a hardware upgrade, while this other idea might be do-able with firmware tweaks. :slight_smile:

I definitely have a RGBW bulb included to a C7 hub as S2. It erks me because I still need to get the ladder out to exclude/reinclude as S0 so my association works.

Weird, I can’t remember if I’ve tried on my C-7, but I was going by a report consistent with my assumption from a Hubitat user and the fact that the Z-Wave conformance doc lists only S0 and not S2. If it’s indeed already S2, then that’s great (and nevermind my “request”). :joy:

@BertABCD1234 - it only happened on 1 bulb out of 5. I thought it was weird, but that’s why my association wasn’t working all the way. Always happens in the tall overhead light. Never the floor lamp.

1 Like

I thought the bulbs did support S2? At least they are documented as supporting it here: https://support.inovelli.com/portal/en/kb/articles/products-leds-rgbw-a19-lzw42-spec-sheet

@Eric_Inovelli I think an update may be needed here :wink:

Z-Wave Alliance confirms it does not.

@Daweeze - :man_shrugging:

Maybe @bcopeland can give some insight? He has the bulbs too.