Scenes On Red - What am I doing wrong?

So I’m a total noob. Installed the switches, struggled some with the process on my Hubitat, but was eventually able to get everything working. Red dimmers upgraded to 1.48 and my HE C-7 is running

My issue now seems to be with scenes, which I’m setting up for the first time. I setup a rule in Rule Machine following the tutorial for the switch but it’s not controlling properly. Do I need to put the dimmer in a different mode? Do I disable local control? It didn’t seem to help.

The switch is just connected to a standard bulb. I’m using the latest driver from my HE (Inovelli Dimmer Red Series LZW31-SN), which looks to have all the features and from what I read should be ok to use after the most recent update.

I just set up some basic button modes to just get started.

The switch seems to work like a normal switch. Push = On / Pull = Off / Holding dims. I can control the switch from the device page and dashboard.

Am I missing something? Obviously I am. :smiley: What am I missing though?

The first thing you should do is to the “Kitchen - Single Light” device page.
Look at the events screen.
Now for each combination of button actions on the Kitchen light switch see what the Events recognized that action for.

I don’t have the same dimmer as you so mine will be different but for example:

I pushed down 2 times fairly quickly, my events showed “button 3 pushed”

So the “Scene” capability is simply the ability to send different messages to the hub when buttons are pushed in a specific sequence (ie. up twice).
If you had a non scene capable dimmer, the events page would show nothing when you pushed a button twice (except that light would go on).

Looking at your button device setup, the only action you need is the last. The buttons on the dimmer will operate the dimmer without setting anything up.


The screen shot appears to be Button Controller, not Rule Machine (doesn’t matter, just a bit confusing), but it looks to be setup fine.

I don’t know about the HE built in device handler, but the Inovelli handler has a setting labeled “Disable local on/off delay” … if that setting is enabled, it will disable your ability to use the multi-tap inputs (scenes feature) of the switch and you can click it until the paddle falls off; you’ll only ever get button 1 pushed/held.

When I double tap or triple tap, nothing is showing up in events. This is all I see:

The only thing logged is my on and off presses. The lastActivity messages seem to occur when I double or triple press but I don’t see any other info.

What exactly did you mean by “If you had a non scene capable dimmer, the events page would show nothing when you pushed a button twice (except that light would go on).”

It’s definitely RM. I have a Disable Physical On/Off Delay. That was set to Not Set and I changed it to No (Default) for giggles. There was no change.

Also Disable Local Control & Disable Remote Control are both set to No.

Ok @JohnRob, this is interesting. Bum luck for me. I have three of these switches and I just happen to try another one for giggles and got this:

Two of the three switches I have are giving the the events you referenced. Typical luck that the first one I touch is a problem.

What would cause the switch next to it not to work? Should I exclude it, factory reset the switch, and re-include it to see if it fixes the issue?

Just to add more to this. For the switch giving me problem… I’ve noticed the current state for this switch is always on, even when I turn the light off. The state seems to change properly for the switch that work.

The good news is, I was doing everything right. RM works as expected with the other two switches.

You may need to exclude/re-include - that should fix the issue. Before you do that, though, try changing the Hubitat driver to “Device”, then click “save device”. Click “configure”, click “get info”, then “save device”. Then change back to the Inovelli driver.

I would:

  1. verify all three switches are using the same driver.
  2. verify all three switches have all the settings the same.
  3. verify all three have the same firmware (upper right in the device page)
  4. try @bill.d suggestion
  5. do what you suggested (i.e. exclude, factory reset, re include)
  6. contact inovelli customer support.


Thank you both @johnrob and @bill.d. After factory resetting and excluding / including several times the damn switch finally gave up the proper configuration. What a pain… :grin:

Glad you have it going. You might think of this as a learning experience :slight_smile:

BTW this is not the usual case.

1 Like