SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, NZW30, NZW31

I finally moved my two LZW31s over to the Edge driver this week, after notifications broke under the DTH (I could change from one notification to another, but couldn’t turn any of them off). I recreated each of my existing notifications as a scene, with another scene to clear notifications - seems to be working well so far. The scenes are a handy way to manage it since I can add in other devices with RGB capability later without having to edit all the individual routines / rules that trigger them. Thanks!

1 Like

I see my Blue series 2 in 1’s edge drivers was updated last night, but this morning both of mine defaulted back to a single pole switch instead of keeping the settings of dimmer on one and dimmer/ smart three way on the other. It was not too hard to get them switched back because I still had the directions in the box on how to do it. Is this going to happen every time a edge driver is updated? Did anyone else see this happen?

Mine updated yesterday as well. For the 3-way w/an Aux, P22 Aux switch type is now set to None (the default). I have not been watching it so I can’t say it changed yesterday or earlier. However, the Aux still works properly in the 3-way configuration, even though the setting appears incorrect.

Do yours still work properly despite the setting or did you catch this because they’re not?

It sounds like you are doing the configuration at the paddle. You ought to be doing that in the settings section of the device in the App.

I caught this because my AUX three-way was not working, so I also checked my other switch, and saw it was back to on/off, not dimmer.

I was using the paddle, but I assumed (I know, I know never assume :grinning:) that it would update the settings in the app. I have corrected it in the settings of the devices in the app, hopefully this will not happen next time.

Thanks for the quick response!

There is some weird thing with the ST architecture about the settings and not working both ways.


Smartthings currently does not support updating what is shown in the settings programmatically. If you change a setting from the switch it won’t update what is shown in the app. I have requested this from ST developers though.

I did find an issue with the latest ST edge driver that may have changed some of the configuration options that were changed by the button combinations. I have rolled back the changes to investigate. Blue Series 2-1 SmartThings Edge Changelog | VZM31-SN - Switches / General Discussion - Inovelli Community


@EricM_Inovelli first, thank you for everything you do keeping the lights on (literally) and keeping us updated on the process.

I have Red Series switch and dimmers in my setup and noticed the dimmer has a parameter for smart bulb mode while the switch does not. As luck would have it, the switch is the one I’m trying to pair with 2 ilumin smart bulbs.

Is this by design or perhaps something still being worked on for the switch edge driver? For now, I’ve used the physical commands so this isn’t a road lock but surfacing for visibility.

I also noticed that with the dimmer, automations for multi tap work while the switch doesn’t seem to. When setting them up, the dimmer has 1x - 5x taps which was the norm with the IDE.

The switch shows 1x - 6x and includes toggle up, down, pressed, etc.!

The reason that the switch does not have a Smart Bulb Mode (SBM) is because with Disable Local Control (DLC), it isn’t needed. The SBM accomplishes two things. It ensures the dimmer always put out full power and it prevents the paddle from making and breaking the wired load. Since the switch can’t dim, it only needs the latter capability. So when using smart bulbs with a switch, enable DLC i.e. disable the local (paddle) control and turn the switch on remotely (if it isn’t already on). At that point whether or not you Disable Remote (i.e. wireless) control is up to you.

Awesome @Bry thanks for the info! That makes sense.

Any insight on why that on/off switch using latest edge drivers doesn’t support multi tap scene control? I’ve tried a bunch of combinations with no luck on my red series switched.

The red series dimmers all control scene without issue with 2x and 3x touches in my testing

1 Like

None of my production switches are running Edge, just dimmers. I will throw one on the test bench and see if I can replicate your issue. Are you finding that none of the multitaps work?

Reposting with pics - apologies for the typos and reposting. Typing this up with a newborn in my arms and trying not to wake him :joy:.

Your help would be super appreciated! So, to give you as much info as i can:

I’ve got the edge drivers for the red switched using the link in this thread as i did for the dimmers. In fact, i have a mix of dimmers and switches in red series, a few switched in black series, and 2 ilumin bulbs so i subscribed to edge for all of those and have moved all but 1 of each to edge drivers. Dimmers work great so far. Bulbs and black series seem fine though i haven’t heavily used them yet.

Red series switches work for the basic on/off and if i associate a routine to that load coming on or off, that triggers automation successfully but, no matter how i configure the routines for a multi tap (double pressed vs pressed 2 times vs toggled up 2 times etc).


  • Settings do not have physical tap disabled.
    *I’ve tried excluding including again
    *The dimmers on Edge don’t have the issue
    *The Switch on IDE doesn’t have this issue
    *This switched worked fine for multi tap earlier today before the switch over the edge
    *Settings for review:

Of note
The options when setting a routine look very odd to me on a switch. Maybe you guys are trying to sneak in an extra 6x shortcut but these previously only supported up to 5x and the dimmers on Edge show 5x is still the cap so, that doesn’t match. More interesting though, instead of the routine trigger having 7 options per button (Pressed, Held, Pressed 2 times, Pressed 3 times, Pressed 4, times, Pressed 6 times Held down for up, down, and config)

I’m seeing 22 options per button and many seem like duplicates (pressed 2 times vs toggled 2 times).

is it possible the mapping on the latest driver is off or somehow wrong and a rollback or update is needed?

Thanks again for your help!

This seems to be what @Triplethreat117 is inquiring about. I don’t have a switch on Edge and production. Were you able to flush this out?

So this is working, but the menu options need to be cleaned up a bit. If you want the double-tap up, for now use up button double-pressed. (Same as “Pressed 2 times” on the dimmer. Held also works . . it will fire on release. So does the config button. That ought to get you going until this gets cleaned up.

I have cleaned up the button options for the LZW31-SN and will be implementing those changes to the other devices soon.

1 Like

Thank you @Bry @anon640257 and @EricM_Inovelli for the stellar work and your responsiveness here!

I do see the options cleaned up on the red dimmers but my problem is with the red on/off switches and unfortunately, double pressed and held on the up, down, and config button also didn’t work for me on the device in question. These were suggested as working shortcuts to hold me over by @Bry so we know they currently work for some.

That said, i have a bit of good news: moments ago i removed and reinstalled both red series on/off switches i was troubleshooting with and after reinstalling, both, do now at least support double pressed.

Not sure if i didn’t get a recent update, edge drivers didn’t install right, etc but, after a reinstall, we can manage with the available shortcuts while you guys work on the rest.

If there is anything I can do to help, let me know. Logs, screen recordings, etc I’m up for it.

Just a guess here, but what happens occasionally is that when you add a device, it adds, but does not add fully. When that occurs, the switch only has partial functionality, such as what you experienced. Removing and re-adding the device, as you did, is the solution.

While it’s around, you can look at the raw description in the IDE. For devices that didn’t add properly, the details will not have been populated properly, displaying zeroes instead of the proper data.

I’m guessing this is what happened to your device the first time around.

1 Like

@Triplethreat117 I have made the button press changes to the Red On / Off. I’ve also added the ability to set a different color for when the switch is on vs off. This is done via SmartThings for the Gen 2 Z-Wave stuff and not in the firmware like the Blue series. So there is a little bit of a delay when the switch turns on or off if the colors are set different. At least it mostly works and lets me re-use the capabilities in the Red and Blue.


@EricM_Inovelli good thinking - i do see the delay but it’s nothing crazy especially when talking notifications maybe 3s max?

I also woke up this morning to “double press” no longer working but a quick look at the routine settings revealed your update in place and now everything is cleaned up and seems to work - 3x at least works as expected so thank you for that.

1 Like

It is also faster on the on / off.

I’ve updated the black series now to also support the LED color capabilities instead of the regular color capability. Now all of these devices should be prevented from showing up in Alexa as color bulbs.

Hi, since the update, in a scene we can’t update the LED bar color/level if we turn off the switch. LED options only appear if we turn On the switch. Can we enable LED options independently of the switch command ?