SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, NZW30, NZW31

LED Color, Notifications, and default level are currently supported with custom capabilities. I can add local and remote control the same way.

Please do! When done, I would love to test. BTW, I have the black series.

I worked on it some today. I should have it available this week some time.


Looking forward!

I’ve added “Local Protection” to the LZW31-SN. I will add it to the other drivers as soon as possible. Remote protection will be added after that.





Very excited. I downloaded the driver. Once the black series has both controls, I’ll delete one of my devices, and readd with this driver to test.

So I bit the bullet and started testing the edge driver on one of my switches. For some reason, I can’t change the settings to get the same “instant” on/off behavior from the physical switch. Going down the options, I changed the first four to 0 with the button ms to 100. Then I changed the first 4 options to 3, 101, 0, and 0 with the same results. It still seems to take a second for the switch to turn on. Any thoughts on this?

Another question. How do I automate that the light turns off and the led changes color? Right now I can only change the color of the led by turning the light on. I have old routines where then light bar changes colors based on the mode, regardless whether the regular switch is on or off.

Not sure . . . maybe you need to set your minimum level? I tried all 0s and everything seemed to work for me. Maybe your minimum level needs to be higher if your bulb doesn’t turn on until it gets to a higher percentage.

This is a quirk of SmartThings. You just have to deselect “Turn on” in the routine when you create it. By default it is set to “Turn on”.

I’ll try changing the min/max later.
Regarding the led color control… Smartthings believes that the on and off and color functionality are for the same device. So it makes sense that you need to turn on the light for the color to change. However, in reality, these are two separate controls. The on/off is for the switch and the color is for the LED. Therefore, there needs to be a way to change the led color without forcing the switch to turn on. It used to be that we were able to use a child device which controlled the on off and color of the led,as well as the dimming. That was great! Right now, it looks like the current implementation is loosing a lot of that functionality. Is it possible to change the driver such that the led has its own on/off dimming from the switch itself?

So I tried playing around with the min max levels and the min is definitely not working. Maybe the max as well. I checked the bulbs at the level where they are still clearly on, then set the min to that value. Then input on the dimmer to a value lower than that. If I understand correctly, the new level 1 should be the number I put in. Therefore, any number hightler should work. It didn’t. It could be some of my other delay settings aren’t working either. Any reason why the button press delay has a min of 100ms and not 0?

I don’t understand what you are mean. For me the color control changes the color of the LED without turning on the load. From the main view of the device and in Routines (as long as I don’t leave “Turn on” enabled like it is by default).



Are you using the same driver as me LOL? I tried another dimmer and all of these functions are working. I don’t know what is going on. I’ll try with another hub to see if I can see what you are seeing. I don’t think there is an easy way to see the logs for edge drivers at this point. Unless you want to download the SmartThings CLI tool.

The valid values for this parameter are (1) 100ms - (9) 900ms. I think it has always been that way. You can effectively set it to 0 by changing the next parameter to disable the on/off delay.

Thanks for your quick response.
So I learned something new today. I didn’t know you can deselect from the ‘Turn on’ and ‘Turn off’. I thought it had to be one or the other. This definitely helps me for my automations. Although, anyone who wants to automate the brightness of the LED or to turn the LED On/Off won’t be able to with this edge driver.

Regarding the delay. Thank you. I missed the ‘disable the on/off delay’. I’m not even sure the user-case to have a delay, but this worked for me. Thanks! As for the min/max, I’m currently still using up some old non-LED bulbs, so it isn’t really a problem right now.

Looking forward to the disable local / remote control.


Unfortunately if you disable the delay, then scenes don’t work. Also, a lower delay can make scenes seem impossible to activate. I find that 400ms is pretty good for me. I can still activate the scenes and get rid of some of the delay. If I set it to 300ms to 100ms then I can’t tap fast enough to activate the scene.

Yeah, that is something I will have to add later as another capability.

Local control is there for the Red Series. It will be coming to the others soon!

I’m on black series. So a delay is not necessary for scenes. Even defaulting to no delay might be ideal.

Waiting patiently… thanks again!

I added the capability of “remoteControl” and “localControl” to the Black Series Dimmer. Might take a few hours to get pushed out, but it should be there.

I’m testing it some more and then will push it out to the other devices.

1 Like

This is what I see. Should I wait longer?

That is a black dimmer? With a color control??

Yes. That is what the old groovy child devices also had.

So, I was able to see the remote control via automations, not the device page itself. I setup a couple of test scenes. I found that I try to control a few options at once, not everything took properly. Usually 1 did, but never all. See below for sample. I also noticed that I couldn’t set the switch to turn off and then also turn off local control. All options are greyed out with switch off. Finally, if I make any routine with one option set, the whole device is unavailable for me to use again in the same routine. Let’s say, for instance, I want the lights to turn off immediately, but I want the remote control to be disabled in 30 seconds, I can’t do that. I know with some other devices in smartthings, I can reuse devices in the same routine, but the specific option I had already used is no longer available for the second go around.

Got it. No child devices with Edge so that makes sense. Seemed strange at first glance.

1 Like