SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

Red series are Z-wave.

1 Like

The OP is using a red series dimmer, which is the Z-Wave. This thread pertains to all Edge drivers so you will find posts relating to both protocols here.

1 Like

Got it, my bad.

Just curious if there is an ETA for adding the individually addressable LED settings to the edge driver for blue series.

Can you shed some more light on how to achieve the child devices for the fan/light switch?

  1. create a virtual device; these two are popular, I happen to be using the first one but the other one should also work fine. Make sure your device is a dimmer type. Name it for whichever component isn’t showing up on your voice assistant (I don’t have a fan/light so not sure).
    [ST Edge] Virtual Things Edge Driver - Community Created Device Types - SmartThings Community
    [ST Edge] vEdge Creator: a virtual device generator for end users - Community Created Device Types - SmartThings Community
  2. Create automation(s) to link the virtual device with the child device.
  • If you’re in a region where Smart Lighting is available, the new Smart Lighting plugin includes a “mirror” option. go to “create routine”, “discover” tab at bottom right, scroll all the way down to “Smart Lighting” (lightbulb icon).
  • Select + to add a new lighting routine. Devices to control: select the child device. Actions: “Sync with switch”. Select devices: select your virtual switch.
  • If you don’t have Smart Lighting, you would need to mimic the above using Routines, with one routine for on and another for off. I’m not sure if there’s a good way to match dimming in routines, if that’s something you’re worried about, but simple on-off should be straightforward.
1 Like

Question for the group and @EricM_Inovelli: I have switched over all my switches and dimmers to Edge drivers and they are mostly working great. However, I have a few issues with the fan/light driver that I hope someone can weigh in on. I checked around the community and over on the ST community before posting.

First issue - I am unable to see other icon options when I select ‘edit’ in ST for the fan/light switch. The default icon choice is the switch, but it would be great to have a ‘fan’ icon or even any of the default ST light icons to select from. Is this possible?

Second issue - When I go to create a lighting group in ST, the fan/light device cannot be selected or discovered in the list of lights or switches to allow grouping. NOTE: I am not using Zwave associates or anything like that. For example, I am trying to create a bedroom zone light group that includes another Inovelli black on/off switch installed in another bedroom, and the black on/off switch appears in the ST lighting group selection list

Third Issue - This is more of a question than an issue per se. What is the difference in functionality between the ‘fan local control’ setting within the ST settings option (this is where you select the 3 dots in the upper right corner, click settings) VS. the ‘fan local control’ setting on the device view (ie. this is after you click on the fan/light tile in ST where you can quickly select on/off, select the light temperature, bulb colour etc.). In the settings, the option is 0-99, on the device view page, it is 0-101. On the device view page, the default setting is 101.

Any help is greatly appreciated.

Great work here! I have 5 NZW37 dual outlet plugs and am hoping to convert to edge but I don’t see any info on them specifically with all the focus on the newer items. Will these eventually get drivers or a workaround once the ide shuts down?

Thank you for the info. I was able to get virtual devices created, but I’m unsure how to “mirror” them to the child devices. I can’t seem to find any child devices in the list of devices. I do see devices titled “switch1” and “switch2”, but when I try to mirror these, nothing happens. Does the current fan/light edge driver include child devices?

I just had a terrible experience where my Smartthings stopped being able to control the Inovelli Dimmer Black v2 around a week ago. I couldn’t delete the dimmer from the phone app and had to log into the Smartthings website to delete it. Then, the dimmer switch wouldn’t pair again with the QR code despite being put into the flashing blue discovery mode. I had to manually click on the link in this thread and install the right device’s edge driver, and had to look up my order history to figure out what device I had. Then I tried a Zigbee exclude using the app and the switch’s discovery function, which didn’t work. Finally, I found documentation on how to factory reset the switch using the button, and finally it was able to pair again with the Smartthings app. I had to redo all of my custom values which I have long since forgotten.

I am disappointed that Samsung wasn’t able to migrate it automatically as they implied most devices would be able to do in their e-mail.

Samsung is still in the Edge migration process. Some classes of devices have been migrated and some not. As of now, Inovelli devices have not. But ultimely, they will, so if you had waited that would have taken place probably by the end of the year.

But that being said, you want the Inovelli-produced driver anyway, so it’s good you got that installed. You would still have had to do that even if Samsung migrated your switch.

It’s not unusual for a Zwave device to not re-pair, depending on how you removed it. So as you discovered, just open the hub utilities and do a Zwave exclude. And I’m sure you now realize that if you are not going to remember your settings, screenshot them before you remove the device or change the driver.

1 Like

I think you mean Zwave exclude.

As Bry said, the migration hasn’t been completed yet. I installed the Inovelli Edge driver for my red and black switches, and will wait for the auto-migration to take place which is scheduled to be completed before Jan 1, 2023.

@EricM_Inovelli Any updates on this? I’ve tried searching the Smartthings forums, but am still unable to find out how to control the child devcies of an edge multicomponent. When I open the Smart Lighting automation app, I’m pretty sure those “switch1” and “switch2” devices correspond to my fan/light switches, but when I try to “mirror” their behavior with the virtual switches I created, nothing happens. I’m a little bummed about this situation since I’m unable to use the old Groovy DTH and therefore can’t control the fan or light individually with any voice assistants. I’m truly considering buying a hubitat or converting my Homebridge to HA and buying a Nortek USB stick. If you have a recommendation on either of those, please let me know.

I don’t have the fan/light switch but I do have a Hampton Bay fan controller with the same type of setup. I don’t need voice control of the light since I manage that with scenes, so this hasn’t been something I needed to figure out, but I can use that as a basis to explain since nobody’s answered with direct experience.

One of the devices should be controllable from the Room it’s in. Call that primary. For me, it’s the fan; I don’t know if that’s true for the Inovelli switch as well. The other device is the secondary device. The primary device should be reachable from your voice assistant without any extra effort.

On my screen, the second switch is labeled “light” so it’s clear which is which. If that’s not present, @EricM_Inovelli should be able to add the label in the driver to make it more understandable. The first screen is how it appears on the device page. The second is how it appears when selecting a device to control in smart lighting.

I just tried setting up the sync with a virtual dimmer. I can get on/off control of the light, but the dim command goes to the fan when it should go to the light. I don’t know whether that bug is in smart lighting or the driver (probably SL).
Here’s the rule I used:

The light is the device to control, and the virtual dimmer is the device controlling it. I’m not home to witness but from what I can see in the app, on/off is working properly but dimming commands are sent to the wrong target.

Thank you for your response. What you’re saying makes complete sense. Unfortunately, I think there are a few issues with being able to apply your solution to the Inovelli fan/light.

  1. The fan light’s primary component is a combo of both controls, fan and light. If I try controlling that device from Alexa both light and fan come on/off.
  2. The driver for the fan/light doesn’t have any labels attached to the components within the smart lighting app and they also don’t seem to anything when I try toggling them using a virtual switch. I have attached some screenshots below, which I hope illustrate what I’m trying to describe.

Device List within Smart Lighting (I have 3 fan/light combos - you can see the 3 switch1’s and switch2’s)

Primary device seems to be “Main”, which controls both fan and light simultaneously

Then below that are the fan and light controls

Got it - then I agree, you would need two (or really six!) virtual dimmers.

I think ST changed some of this relatively recently to allow labeling the devices the way my screenshot shows. It would require Inovelli to update the driver to take advantage; it’s also now possible to create child devices but I haven’t heard that it was officially released or documented.

@EricM_Inovelli have you heard anything about these ST changes or are there any plans to update the driver for the LZW36?

Yes, I do plan on updating the driver at some point. I spent a couple days on it a bit ago, but could not get the “child” devices to update their status. I had a lot of other issues I was falling behind on and had to put it on hold. I do plan to revist it though. Maybe when there is some more documentation from the ST engineers.

Side note: I pushed an update for the LZW31-SN to use custom capabilities to control the LED color / level. This should stop the devices from showing up as color bulbs in Alexa. I am re-using the capabilities from the 2-1 which has a separate led color when the light is off. This is not supported on the LZW31-SN so it will not work of course, but the “level” portion of the capability does work.



I finally moved my two LZW31s over to the Edge driver this week, after notifications broke under the DTH (I could change from one notification to another, but couldn’t turn any of them off). I recreated each of my existing notifications as a scene, with another scene to clear notifications - seems to be working well so far. The scenes are a handy way to manage it since I can add in other devices with RGB capability later without having to edit all the individual routines / rules that trigger them. Thanks!

1 Like

I see my Blue series 2 in 1’s edge drivers was updated last night, but this morning both of mine defaulted back to a single pole switch instead of keeping the settings of dimmer on one and dimmer/ smart three way on the other. It was not too hard to get them switched back because I still had the directions in the box on how to do it. Is this going to happen every time a edge driver is updated? Did anyone else see this happen?