SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

I’ve tried this setup and unfortunately I cant seem to get it to work correctly. I have 3 LZW36 (fan+light) switches that are no longer able to be used outside of SmartThings because of this.

Creating the virtual devices and setting up the SmartLighting automations works fine. But no matter which ‘device’ (no label, switch1, switch2) I select to control from the LZW36, it controls both fan and light together.

Wondering if anyone has been able to figure this out?

Also, is the edge driver source code available publicly?

I found the same thing setting up a “Sync with Switch” automation on a different fan+light. I think SmartLighting has a bug with using Sync for multi-endpoint devices, and maybe that’s just an uncommon enough use case that it hasn’t been addressed. I stopped fooling with it because I don’t actually need it, but it would be worth submitting a bug report if you’re able.

I created virtual switches and then just created 2 routines per switch. If office fan virtual switch is on, turn on office fan, and then another for if office fan virtual switch is off, turn off fan. Then did the same for the light. Then the virtual switches pulled into Alexa, made sure that I had them named office fan and office light and they work fine. Make sure that in the options for the fan switch you don’t select main switch as the switch to cycle with the virtual switch.

I noticed yesterday that this driver stopped working with my LZW30 switch. It stopped updating status and routines that used it asna trigger stopped working. I switched it to a third party edge driver, and it works with that one. I’ve tried switching back to this official one several times, and the problem returns every time I do.

Have you tried rebooting the switch by pulling the air gap or throwing the breaker?

Yes, I did, but that didn’t solve it. Neither did rebooting the SmartThings hub, nor performing a Z-Wave network repair/rebuild. Eric just responded elsewhere that he found the error and is pushing out a fix tonight.

I pushed out the fix but it might take a few hours to reach your hub. SmartThings changed a value of a constant in their system and it is probably going to break multiple drivers (unless they roll it back). I have removed the constant from our drivers for now.


Any update or progress for LZW45 light strips? Is there a way to configure effects with edge driver?

Eric, I’m having the same problem with the new edge driver for the First Gen switch (NZW30).

I’m sorry, I am not seeing the error with that driver and I don’t use the same constant variable with the first gen drivers. Can you show me the screenshot of the driver page for the device so I can see the details of it?

Boy - I was not expecting this. Turns out that I just spent that last 3 days reloading my complete Smartthings configuration so that everything would be on edge drivers, and when I got to reloading my routines to control the LED light notifications - I was running into this problem . I started at the top of the thread and kept thinking I was dreaming beacuse I wasn’t seeing what others were seeing. Little did I know it was because of my iPhone. Unbelievable. Just spent the morning updating the firmware, thinking it was the problem. Just dug out one of my old Android phones so I can run the Smartthings app and set up the routines for LED control.

In my move to the edge drivers I could not get Notifications to work on my Red Dimmer Switch’s.
For my migration I deleted everything (all drivers, smartapps, hub, etc.). Conducted a factory reset on the Smartthings hub and all the devices that had a procedure to conduct a factory reset (including all Inovelli devices), then reinstalled everything. This took better part of one day. After it was done the notification feature on the Red Dimmer switches did not work. The Notification feature worked on my two Red on/off switches. The edge driver for the Red Dimmer switch is - 2023-01-25T04:50:50.45263647. The edge drived for the Red switch is - 2023-01-25T04:36:24.278657753.
Just by chance I found out that after the factory reset on the dimmer switches the Notification duration setting must have been set to zero seconds. When I ran a Scene to set the Notification duration to some value (like 24 hours) the Notification feature started working.

That is weird, I wonder how that ended up getting changed. So this was a routine that had multiple switches in it and the duration was set to 0? So when you added the switch back to it the notifications did not work?

I don’t know it was set to zero. I failed to look at what the Notification duration was set to before I asked for it to be changed. The value that I used was 24 hours. So I am guessing a little on this as to what the orginial value is. What I can say is that untill I changed the value for Notification duration, Notifications were not being displayed on the Red Dimmer switch.
I tried routines that had multiple switches and one that sent a notificaiton to just one of the switches with the same effect of not seeing the notification. What I did observe is that when I sent 1 switch or multipule a Notification the Notification type would get changed, because I could view it from the device screen. I do not know how to see Notification color or duration.
Yes, when I added back the each Red Dimmer switch back after the full Smartthings reset, none of them would display a Notificaiton. Afterwards, I also tried excluding and re-adding the switch to the same effect. I even thought maybe it was the firmware (started with 1.47). So I also excluded each Red Dimmer switch, updated the firmware to 1.57, added it back - to the same result.

Was the update that was pushed for the light/fan driver, or a different product?

I’m still having the same issue. Driver version reads 2022-10-04.

Can you let me know the symptoms of what is happening? I’ll look into the light/fan driver right now.

Hey! Looking for some help.
I have several Inovelli Red series Dimmers
I can’t get them to see the edge drivers. I have installed the edge drivers from here -

Removed my devices using ZWave exclusion and then re-added them.

I have also unenrolled my hub from the drivers, deleted the drivers and re-enrolled.

I can’t seem to get the devices to see the edge driver.

Any ideas welcome. I would love to utilize the features I had before edge.


Not sure where to ask this, so here we go.
I just upgraded all my switch and red series dimmers to the edge drivers.
Worked like a charm.
Now I’m trying to set up the notifications I had before.
Example, I want the LED bar on a red series Dimmer to be on and yellow when the light in the attic is on (a black series switch) and turn off when the light is off. I simply can’t figure out what to use in SmartThings. A routine or Smart Lighting?
How do I configure the notifications?

Another example is to have the light bar flash red when the front door is unlocked then when it’s locked have it flash green for 3 seconds and turn off. I used to have this notification on three different red series dimmers

I couldn’t find any description on how to configure notifications.
Any help would be appreciated

That is the proper link to enroll. After you did that, did you click on the “Available Drivers” button and then install the specific drivers you need?



Use routines.

For the attic light, you’ll need two.

If Black Attic Switch: ON, THEN
Control Devices, Inovelli you want the notification on, deselect the On or Off at the top, then set the notification preferences. Effect, Color, Level and Duration. You must set all 4 for the notification to work.

For the off rule, IF Black Attic Switch OFF, THEN
Control Devices, Inovelli you want the notification on, deselect teh On or Off at the top, then set the Notification Effect to OFF.

If you can’t get the other one after getting this one going, post back.

1 Like