SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN, VZM35-SN, VZW31-SN, VZM36, NZW30, NZW31

@EricM_Inovelli Any updates on this? I’ve tried searching the Smartthings forums, but am still unable to find out how to control the child devcies of an edge multicomponent. When I open the Smart Lighting automation app, I’m pretty sure those “switch1” and “switch2” devices correspond to my fan/light switches, but when I try to “mirror” their behavior with the virtual switches I created, nothing happens. I’m a little bummed about this situation since I’m unable to use the old Groovy DTH and therefore can’t control the fan or light individually with any voice assistants. I’m truly considering buying a hubitat or converting my Homebridge to HA and buying a Nortek USB stick. If you have a recommendation on either of those, please let me know.

I don’t have the fan/light switch but I do have a Hampton Bay fan controller with the same type of setup. I don’t need voice control of the light since I manage that with scenes, so this hasn’t been something I needed to figure out, but I can use that as a basis to explain since nobody’s answered with direct experience.

One of the devices should be controllable from the Room it’s in. Call that primary. For me, it’s the fan; I don’t know if that’s true for the Inovelli switch as well. The other device is the secondary device. The primary device should be reachable from your voice assistant without any extra effort.

On my screen, the second switch is labeled “light” so it’s clear which is which. If that’s not present, @EricM_Inovelli should be able to add the label in the driver to make it more understandable. The first screen is how it appears on the device page. The second is how it appears when selecting a device to control in smart lighting.

I just tried setting up the sync with a virtual dimmer. I can get on/off control of the light, but the dim command goes to the fan when it should go to the light. I don’t know whether that bug is in smart lighting or the driver (probably SL).
Here’s the rule I used:

The light is the device to control, and the virtual dimmer is the device controlling it. I’m not home to witness but from what I can see in the app, on/off is working properly but dimming commands are sent to the wrong target.

Thank you for your response. What you’re saying makes complete sense. Unfortunately, I think there are a few issues with being able to apply your solution to the Inovelli fan/light.

  1. The fan light’s primary component is a combo of both controls, fan and light. If I try controlling that device from Alexa both light and fan come on/off.
  2. The driver for the fan/light doesn’t have any labels attached to the components within the smart lighting app and they also don’t seem to anything when I try toggling them using a virtual switch. I have attached some screenshots below, which I hope illustrate what I’m trying to describe.

Device List within Smart Lighting (I have 3 fan/light combos - you can see the 3 switch1’s and switch2’s)

Primary device seems to be “Main”, which controls both fan and light simultaneously

Then below that are the fan and light controls

Got it - then I agree, you would need two (or really six!) virtual dimmers.

I think ST changed some of this relatively recently to allow labeling the devices the way my screenshot shows. It would require Inovelli to update the driver to take advantage; it’s also now possible to create child devices but I haven’t heard that it was officially released or documented.

@EricM_Inovelli have you heard anything about these ST changes or are there any plans to update the driver for the LZW36?

Yes, I do plan on updating the driver at some point. I spent a couple days on it a bit ago, but could not get the “child” devices to update their status. I had a lot of other issues I was falling behind on and had to put it on hold. I do plan to revist it though. Maybe when there is some more documentation from the ST engineers.

Side note: I pushed an update for the LZW31-SN to use custom capabilities to control the LED color / level. This should stop the devices from showing up as color bulbs in Alexa. I am re-using the capabilities from the 2-1 which has a separate led color when the light is off. This is not supported on the LZW31-SN so it will not work of course, but the “level” portion of the capability does work.



I finally moved my two LZW31s over to the Edge driver this week, after notifications broke under the DTH (I could change from one notification to another, but couldn’t turn any of them off). I recreated each of my existing notifications as a scene, with another scene to clear notifications - seems to be working well so far. The scenes are a handy way to manage it since I can add in other devices with RGB capability later without having to edit all the individual routines / rules that trigger them. Thanks!

1 Like

I see my Blue series 2 in 1’s edge drivers was updated last night, but this morning both of mine defaulted back to a single pole switch instead of keeping the settings of dimmer on one and dimmer/ smart three way on the other. It was not too hard to get them switched back because I still had the directions in the box on how to do it. Is this going to happen every time a edge driver is updated? Did anyone else see this happen?

Mine updated yesterday as well. For the 3-way w/an Aux, P22 Aux switch type is now set to None (the default). I have not been watching it so I can’t say it changed yesterday or earlier. However, the Aux still works properly in the 3-way configuration, even though the setting appears incorrect.

Do yours still work properly despite the setting or did you catch this because they’re not?

It sounds like you are doing the configuration at the paddle. You ought to be doing that in the settings section of the device in the App.

I caught this because my AUX three-way was not working, so I also checked my other switch, and saw it was back to on/off, not dimmer.

I was using the paddle, but I assumed (I know, I know never assume :grinning:) that it would update the settings in the app. I have corrected it in the settings of the devices in the app, hopefully this will not happen next time.

Thanks for the quick response!

There is some weird thing with the ST architecture about the settings and not working both ways.


Smartthings currently does not support updating what is shown in the settings programmatically. If you change a setting from the switch it won’t update what is shown in the app. I have requested this from ST developers though.

I did find an issue with the latest ST edge driver that may have changed some of the configuration options that were changed by the button combinations. I have rolled back the changes to investigate. Blue Series 2-1 SmartThings Edge Changelog | VZM31-SN - Switches / General Discussion - Inovelli Community


@EricM_Inovelli first, thank you for everything you do keeping the lights on (literally) and keeping us updated on the process.

I have Red Series switch and dimmers in my setup and noticed the dimmer has a parameter for smart bulb mode while the switch does not. As luck would have it, the switch is the one I’m trying to pair with 2 ilumin smart bulbs.

Is this by design or perhaps something still being worked on for the switch edge driver? For now, I’ve used the physical commands so this isn’t a road lock but surfacing for visibility.

I also noticed that with the dimmer, automations for multi tap work while the switch doesn’t seem to. When setting them up, the dimmer has 1x - 5x taps which was the norm with the IDE.

The switch shows 1x - 6x and includes toggle up, down, pressed, etc.!

The reason that the switch does not have a Smart Bulb Mode (SBM) is because with Disable Local Control (DLC), it isn’t needed. The SBM accomplishes two things. It ensures the dimmer always put out full power and it prevents the paddle from making and breaking the wired load. Since the switch can’t dim, it only needs the latter capability. So when using smart bulbs with a switch, enable DLC i.e. disable the local (paddle) control and turn the switch on remotely (if it isn’t already on). At that point whether or not you Disable Remote (i.e. wireless) control is up to you.

Awesome @Bry thanks for the info! That makes sense.

Any insight on why that on/off switch using latest edge drivers doesn’t support multi tap scene control? I’ve tried a bunch of combinations with no luck on my red series switched.

The red series dimmers all control scene without issue with 2x and 3x touches in my testing

1 Like

None of my production switches are running Edge, just dimmers. I will throw one on the test bench and see if I can replicate your issue. Are you finding that none of the multitaps work?

Reposting with pics - apologies for the typos and reposting. Typing this up with a newborn in my arms and trying not to wake him :joy:.

Your help would be super appreciated! So, to give you as much info as i can:

I’ve got the edge drivers for the red switched using the link in this thread as i did for the dimmers. In fact, i have a mix of dimmers and switches in red series, a few switched in black series, and 2 ilumin bulbs so i subscribed to edge for all of those and have moved all but 1 of each to edge drivers. Dimmers work great so far. Bulbs and black series seem fine though i haven’t heavily used them yet.

Red series switches work for the basic on/off and if i associate a routine to that load coming on or off, that triggers automation successfully but, no matter how i configure the routines for a multi tap (double pressed vs pressed 2 times vs toggled up 2 times etc).


  • Settings do not have physical tap disabled.
    *I’ve tried excluding including again
    *The dimmers on Edge don’t have the issue
    *The Switch on IDE doesn’t have this issue
    *This switched worked fine for multi tap earlier today before the switch over the edge
    *Settings for review:

Of note
The options when setting a routine look very odd to me on a switch. Maybe you guys are trying to sneak in an extra 6x shortcut but these previously only supported up to 5x and the dimmers on Edge show 5x is still the cap so, that doesn’t match. More interesting though, instead of the routine trigger having 7 options per button (Pressed, Held, Pressed 2 times, Pressed 3 times, Pressed 4, times, Pressed 6 times Held down for up, down, and config)

I’m seeing 22 options per button and many seem like duplicates (pressed 2 times vs toggled 2 times).

is it possible the mapping on the latest driver is off or somehow wrong and a rollback or update is needed?

Thanks again for your help!

This seems to be what @Triplethreat117 is inquiring about. I don’t have a switch on Edge and production. Were you able to flush this out?

So this is working, but the menu options need to be cleaned up a bit. If you want the double-tap up, for now use up button double-pressed. (Same as “Pressed 2 times” on the dimmer. Held also works . . it will fire on release. So does the config button. That ought to get you going until this gets cleaned up.

I have cleaned up the button options for the LZW31-SN and will be implementing those changes to the other devices soon.

1 Like