SmartThings Edge Drivers: LZW30-SN, LZW30, LZW31-SN, LZW31, LZW36, LZW41, LZW42, LZW45, LZW60, VZM31-SN

So… this is weird. It doesn’t show as connected to my Hub… but then again, it doesn’t look like many of them do. A lot of the edge driver stuff just says placeholder for the type. Then nothing else.
|Name|inovelli-dimmer-power-energy|
|Label|Office Closet Light|
|Type|placeholder|
|Version|Published|
|Status|ONLINE|
|Group|Office Closet|
|Last Activity At|2022-11-08 5:02 PM EST|
|Date Created|2022-10-20 8:20 PM EDT|
|Last Updated|2022-10-24 9:27 PM EDT|
|Data|No data found for device|
|Current States|No states found|
|Execution Location|Cloud|
|Events|List Events|
|Child Devices|* button1

Okay, so you’re looking in the IDE, which is okay but less useful under Edge. Since it says Placeholder that indicates you are using an Edge driver but the question is which one.

Did you load the Inovelli Edge drivers before installing the switch? To see which driver you are using, in the app, open that device. Select the Driver menu from the three dot menu top right. It should say Inovelli Dimmer Red Series.

image

I did have the driver installed before I installed the switch.

At first, when I opened the switch, Driver was grayed out. I walked over to the switch and hit the ‘off’ button and then it came awake in ST. Then, I was able to get this screenshot.

Hard to say what’s going on, but here is a suggestion. Occasionally a switch will add to the hub but not perfectly. It will work sometimes but it’s intermittent. With a Groovy driver, you could look in the IDE and tell that it did not add completely. Under Edge, however, I don’t know of any way to tell the same thing.

So I’d suggest removing the switch, factory reset it, and then re-add it. See if it behaves any better.

Long press on the config about 40 seconds until it turns red to factory reset.

Also, do a Zwave repair after you add it,

Ok will do that tomorrow! I forgot to mention that I did a zwave repair, as well. A couple times. But I will try to factory reset the switch and try again. Thanks. Crossing my fingers.

Side question… what happens if the QR code has worn off and become unreadable? How can you still use the switch and install it?

The QR code is also on the piece of paper that came with the dimmer. But if you don’t have that for some reason I would add the switch using Scan Nearby. There is some argument that this may be the better way to add the devices anyway. You don’t get the encryption but there is less network traffic, as I understand it.

1 Like

These are zigbee, so that wouldn’t impact this issue, just for the record.

Red series are Z-wave.

1 Like

The OP is using a red series dimmer, which is the Z-Wave. This thread pertains to all Edge drivers so you will find posts relating to both protocols here.

1 Like

Got it, my bad.

Just curious if there is an ETA for adding the individually addressable LED settings to the edge driver for blue series.

Can you shed some more light on how to achieve the child devices for the fan/light switch?

  1. create a virtual device; these two are popular, I happen to be using the first one but the other one should also work fine. Make sure your device is a dimmer type. Name it for whichever component isn’t showing up on your voice assistant (I don’t have a fan/light so not sure).
    [ST Edge] Virtual Things Edge Driver - Community Created Device Types - SmartThings Community
    [ST Edge] vEdge Creator: a virtual device generator for end users - Community Created Device Types - SmartThings Community
  2. Create automation(s) to link the virtual device with the child device.
  • If you’re in a region where Smart Lighting is available, the new Smart Lighting plugin includes a “mirror” option. go to “create routine”, “discover” tab at bottom right, scroll all the way down to “Smart Lighting” (lightbulb icon).
  • Select + to add a new lighting routine. Devices to control: select the child device. Actions: “Sync with switch”. Select devices: select your virtual switch.
  • If you don’t have Smart Lighting, you would need to mimic the above using Routines, with one routine for on and another for off. I’m not sure if there’s a good way to match dimming in routines, if that’s something you’re worried about, but simple on-off should be straightforward.

Question for the group and @EricM_Inovelli: I have switched over all my switches and dimmers to Edge drivers and they are mostly working great. However, I have a few issues with the fan/light driver that I hope someone can weigh in on. I checked around the community and over on the ST community before posting.

First issue - I am unable to see other icon options when I select ‘edit’ in ST for the fan/light switch. The default icon choice is the switch, but it would be great to have a ‘fan’ icon or even any of the default ST light icons to select from. Is this possible?

Second issue - When I go to create a lighting group in ST, the fan/light device cannot be selected or discovered in the list of lights or switches to allow grouping. NOTE: I am not using Zwave associates or anything like that. For example, I am trying to create a bedroom zone light group that includes another Inovelli black on/off switch installed in another bedroom, and the black on/off switch appears in the ST lighting group selection list

Third Issue - This is more of a question than an issue per se. What is the difference in functionality between the ‘fan local control’ setting within the ST settings option (this is where you select the 3 dots in the upper right corner, click settings) VS. the ‘fan local control’ setting on the device view (ie. this is after you click on the fan/light tile in ST where you can quickly select on/off, select the light temperature, bulb colour etc.). In the settings, the option is 0-99, on the device view page, it is 0-101. On the device view page, the default setting is 101.

Any help is greatly appreciated.

Great work here! I have 5 NZW37 dual outlet plugs and am hoping to convert to edge but I don’t see any info on them specifically with all the focus on the newer items. Will these eventually get drivers or a workaround once the ide shuts down?

Thank you for the info. I was able to get virtual devices created, but I’m unsure how to “mirror” them to the child devices. I can’t seem to find any child devices in the list of devices. I do see devices titled “switch1” and “switch2”, but when I try to mirror these, nothing happens. Does the current fan/light edge driver include child devices?

I just had a terrible experience where my Smartthings stopped being able to control the Inovelli Dimmer Black v2 around a week ago. I couldn’t delete the dimmer from the phone app and had to log into the Smartthings website to delete it. Then, the dimmer switch wouldn’t pair again with the QR code despite being put into the flashing blue discovery mode. I had to manually click on the link in this thread and install the right device’s edge driver, and had to look up my order history to figure out what device I had. Then I tried a Zigbee exclude using the app and the switch’s discovery function, which didn’t work. Finally, I found documentation on how to factory reset the switch using the button, and finally it was able to pair again with the Smartthings app. I had to redo all of my custom values which I have long since forgotten.

I am disappointed that Samsung wasn’t able to migrate it automatically as they implied most devices would be able to do in their e-mail.

Samsung is still in the Edge migration process. Some classes of devices have been migrated and some not. As of now, Inovelli devices have not. But ultimely, they will, so if you had waited that would have taken place probably by the end of the year.

But that being said, you want the Inovelli-produced driver anyway, so it’s good you got that installed. You would still have had to do that even if Samsung migrated your switch.

It’s not unusual for a Zwave device to not re-pair, depending on how you removed it. So as you discovered, just open the hub utilities and do a Zwave exclude. And I’m sure you now realize that if you are not going to remember your settings, screenshot them before you remove the device or change the driver.

I think you mean Zwave exclude.

As Bry said, the migration hasn’t been completed yet. I installed the Inovelli Edge driver for my red and black switches, and will wait for the auto-migration to take place which is scheduled to be completed before Jan 1, 2023.