Some Switches not responding to GET OTA Version command?

Hi folks,

I have a bunch of Inovelli Red Dimmers and Switches around the house. I was testing out the latest firmware on one switch, to see if it improved a few minor issues I’ve been noticing. As I tried to upgrade the firmware on the switch I selected, I ran into a roadblock at the step where I have to hit the GET button on the Firmware Update screen in the Z-Wave PC Controller app. When I click it, it looks like it tries to send the command, but nothing happens.

So, i tried another LZW31-SN switch that I have in he house, bought at the same time, same firmware version as far as I can tell, and that one worked! Tried another, didn’t work. Tried yet another, it DID work.

I can’t tell why two of them won’t respond to the Get button, but the other 2 do. They look pretty much the same to me in the Z-Wave controller app. The one thing I noticed is that one of the two that worked shows the FIRMWARE command class when I click Node Info on the network management screen. Does that mean that two of my switches don’t support OTA updates?

Or am I missing something else? Appreciate any advice here. This isn’t a massive issue, but I’d love to understand why some worked and some didn’t.

BTW, none of my Red Switches (the non-dimmer LZW30-SN version) are allowing me to update, nor do they show the command class when I click Node Info…

Thanks - love these products generally, just really trying to understand this a little better.

Sujal

It sounds like your update controller is not connected to the primary controller using S2 authentication, while your switches are connected to the primary controler with S2. Try excluding the update controller, and includ it again making sure to use S2 authentication.

Thanks for replying. Your suggestion pointed me in the right direction.

For anyone else that’s debugging this later, I use Home Assistant as my home automation server. That has the Z-Stick that’s the primary controller for my Z-Wave Network.

You surmised correctly that my switch was added securely - it’s using S0, though, not S2. That made me look into whether the secondary controller was added securely and it turns out it was not. I’m not exactly sure what I did to get this to work, but some combination of these changes made the difference:

  • I unchecked all the S2 options in the security manager in the Z-Wave PC Controller.
  • I checked Join with CSA and made sure S0 was still checked in the security manager
  • I made sure the secondary controller was in direct range of the primary controller, and used the Classic Learn instead of NWI.
  • (this may have helped or made it more complicated, but I checked override for the S0 key, and left it with all zeroes - before Get Info worked below, I had to uncheck the override before it all started working)

I then made sure that the PC Controller showed the same network key on the secondary controller (it did) and it showed [S0] next to the secondary controller entry in the device list.

I did a get info on the switch I was having trouble with and bam! it showed up with an [S0] next to its name, as well. At that point, I was good to go.

Thanks for the suggestion - that was enough to help out. Appreciate you taking the time.

Sujal