ST DTH vs HE Driver Codes

Based on a trigger, I have a WebCore piston in HE that changes the LED color using the SetConfigParameter in Webcore. It seems that SetConfigParameter is not available in ST.

is there a difference between the ST DTH code and the HE Driver code for the LZW31 (black series)?

You are really asking if the color of the LED can be set via webCore in ST, right?

Yes, you can set the color and intensity via webCore in ST. This works for Red dimmers. I don’t have any Black dimmers, so you will have to test.

You have to add the rgbw child device DH in the IDE so that in the switch’s settings you can turn on Create a light LED child device. Once that child device exists, expose it to webCore. Look in the parent DH code for the URLs to the child device code.

In webCore, you are going to address the child device, not the parent. It will have “(Light LED)” after the parent’s name.

You have a several options:

  • Use SetColor and Preset and pick from the colors
  • Use SetColor and Value and select a hex value color
  • Use SetColor…(hsl) and then manually set the Hue, Saturation and Level

You’ll find that you may have to play around with the color specifications you want to achieve as the colors may not wind up exactly as you specify in the piston.

Thank you for your response. I am aware of the child device DH in ST and HE but in HE I address the device directly using the setConfigParameter 13 to change the LED color. It seems that this “command” isn’t available in webCORE /DTH for the LZW31. Here is a snippet in webCore to further explain my question:

Capture d’écran 2022-03-11 122412

Hope this help.

Maybe I’m not understanding your question. You’ve determined that you can’t use the same webCore statement in ST as you do in HE. But at least for parameter 13 (LED color), my post above explains how it’s done in ST, so if that’s what you are trying to accomplish, that is how you do it.

If you are asking about setting ANY parameter using setConfigParameter as you do in HE, then I don’t think there is a ST equivalent.

Thank you.


Is there a way to select the color white? I have tried set color to #fffff, set color to white but when i do the led is showing Red. If i set parameter 13 to white; the correct color is displayed.

Have you tried 0x00FF? The datatype is defined as 16bits (2 bytes) but white is 255=0xFF=0x00FF

If that doesn’t work, try 0xFF00 because it might be litte-endian (I’m not sure)

Yeah, it’s kind of jacked. I’m wondering if the DH isn’t translating properly.

I have tried both and both did not do anything…

Set param 13 to 255. Make sure you are on a recent firmware that has this functionality (1.35 as shipped originally did not).

That is what i must do if i want to return the led to white when i use the led light as notification in my routines. I wanted to automate this process but it seems that it is not possible in ST. Thank you

I think we can figure this out! Help me understand your use case, because there are 2 different color settings:

first is when there are no notifications present, that is parameter 13.
a second is when there is a notification present, which uses the child of the driver for color, type (pulse, etc.), and time (1 second up to infinite).

Are you trying to set the LED Bar Color as white, or send a notification that is white in color?

Here is what i am trying to do in ST (btw it works great in Hubitat using rule machine).

All my Inovellis (i have a mix of black and red switches and dimmers) are setup using White as their default LED color.

Based on various triggers (door open, lock unlocked, and others), i am using the LED colors to notify people in the house. For the RED series it is easy, i am using the LED Notification child devices. For the Black Series, i can also change the LED color child device but when i try to return to its default value, white is showing RED (in Hubitat i can change back parameter 13 to 255 programmatically but not in ST. I have had some success with using the set color temperature to 0K but it fails sometime…


@EricM_Inovelli does this sound like a DTH issue for the black series?

The webCore/LED color issue occurs with red dimmers as well. My suspicion is whatever webCore is sending isn’t getting translated properly.

It is not just webcore, i am getting the same behavior in SharpTool Rule Engine.


Has to be DTH related then… I never had an issue but ditched ST a while ago. Can you post the ST logs during the operation? We might be able to capture what is going on.

Here are the logs from webCore and ST:



In addition, this also came up later when i turned on the SW

I’m kind of stuck here… Will monitor but @EricM_Inovelli might be more qualified to check this.

Not sure if anyone else I know is on Smartthings, I think I’ve converted them all to Home Assistant…